summaryrefslogtreecommitdiff
path: root/src
diff options
context:
space:
mode:
authorLuke Shumaker <LukeShu@sbcglobal.net>2014-01-04 19:39:02 -0500
committerLuke Shumaker <LukeShu@sbcglobal.net>2014-01-04 19:39:02 -0500
commit8698eb5f1dff6d046fb708d1e4f529d83e88cb4c (patch)
tree47df14721d05e356f443271be5907cd9ba0cf1f4 /src
parent6eb64cb5bdce43fb5b1a83f93496083761ea2718 (diff)
librefetch: Update the docs: `version` mode is gone, a while ago.
Diffstat (limited to 'src')
-rwxr-xr-xsrc/librefetch/librefetch2
-rw-r--r--src/librefetch/librefetch.8.ronn6
2 files changed, 3 insertions, 5 deletions
diff --git a/src/librefetch/librefetch b/src/librefetch/librefetch
index eb7eb61..6268d75 100755
--- a/src/librefetch/librefetch
+++ b/src/librefetch/librefetch
@@ -28,7 +28,7 @@ trap cleanup EXIT
cmd=${0##*/}
usage() {
print "Usage: %s [OPTIONS] SOURCE_URL [OUTPUT_FILE]" "$cmd"
- print "Usage: %s -[g|P|V|h]" "$cmd"
+ print "Usage: %s -[g|P|h]" "$cmd"
print "Downloads or creates a liberated source tarball."
echo
prose "The default mode is to create OUTPUT_FILE, first by trying
diff --git a/src/librefetch/librefetch.8.ronn b/src/librefetch/librefetch.8.ronn
index c2b8ffe..16c3838 100644
--- a/src/librefetch/librefetch.8.ronn
+++ b/src/librefetch/librefetch.8.ronn
@@ -4,7 +4,7 @@ librefetch(8) -- downloads or creates a liberated source tarball
## SYNOPSIS
`librefetch` [options] <source-url> [<output-file>]<br>
-`librefetch` -[g|V|h]
+`librefetch` -[g|P|h]
## DESCRIPTION
@@ -18,7 +18,7 @@ package adds `librefetch` as a download agent for `libre://` to
`makepkg.conf`. Because of this, it is almost never necessary to call
`librefetch` manually.
-There are 7 modes:
+There are 6 modes:
* `download-create`: The default mode. First try `download` mode,
then `create` mode.
@@ -26,7 +26,6 @@ There are 7 modes:
* `create`: Create the tarball from a `PKGBUILD`/`SRCBUILD`.
* `checksums`: Generate integrity checks for source files.
* `print`: Print the effective build script.
- * `version`: Print `librefetch` version information.
* `help`: Print `librefetch` usage information.
## OPTIONS
@@ -39,7 +38,6 @@ There are 7 modes:
* `-g` | `--geninteg`: Use `checksums` mode: Generate integrity
checks for source files.
* `-P` | `--print`: Use `print` mode: print the effective build script.
- * `-V` | `--version`: Use `version` mode: Show version information.
* `-h` | `--help`: Use `help` mode: Show useage information.
## CREATE MODE