summaryrefslogtreecommitdiff
path: root/src
diff options
context:
space:
mode:
authorLuke Shumaker <LukeShu@sbcglobal.net>2013-09-23 19:58:09 -0400
committerLuke Shumaker <LukeShu@sbcglobal.net>2013-09-23 19:58:09 -0400
commit03119e29b4bb744478e6e01922da4d50cf4cbcbc (patch)
treef047d3998c323e7cb113682c8905f5cf6148c442 /src
parent16e01bca9a23eef40191e8ca5abefdb1ab4c741a (diff)
Makefile: fix xgettext rules
Diffstat (limited to 'src')
-rw-r--r--src/chroot-tools/Makefile3
-rw-r--r--src/lib/Makefile11
2 files changed, 7 insertions, 7 deletions
diff --git a/src/chroot-tools/Makefile b/src/chroot-tools/Makefile
index 0540636..db1cdf5 100644
--- a/src/chroot-tools/Makefile
+++ b/src/chroot-tools/Makefile
@@ -40,5 +40,4 @@ archroot: %: %.in Makefile
@$(edit) <"$<" >"$@" || { rm -f -- '$@'; false; }
@chmod 755 "$@" || { rm -f -- '$@'; false; }
-distcc-tool.pot: distcc-tool
- xgettext --omit-header -i --from-code=UTF-8 -L shell --keyword={error,errusage} -o $@ $<
+distcc-tool.pot: xgettext-keywords-sh+=--keyword=errusage
diff --git a/src/lib/Makefile b/src/lib/Makefile
index 45fd330..fd6d31d 100644
--- a/src/lib/Makefile
+++ b/src/lib/Makefile
@@ -23,8 +23,9 @@ pot: libreblacklist.pot common.sh.pot librelib.pot
libreblacklist.pot: libreblacklist
{ \
- sed -n '/^# Usage:/,/()/{ /^#/ { =; p; } }' $< | sed -r -e 's/^# (.*)/msgid "\1"/' -e 's/^[0-9]*$$/#. embedded usage text\n#: $<:&/'; \
- sed -rn '/print /{ =; s/\s*print "([^"]*)".*/msgid "\1"/p; }' $< | sed 's/^[0-9]*$$/#. print\n#: $<:&/' ; \
- } | sed 's/^msgid .*/&\nmsgstr ""\n/' > $@
-common.sh.pot: common.sh
- xgettext --omit-header -i --from-code=UTF-8 -L shell -o $@ $<
+ sed -n '/^# Usage:/,/()/{ /^#/ { =; p; } }' $< | \
+ sed -r -e 's/^# (.*)/msgid "\1"\nmsgstr ""\n/' \
+ -e 's/^[0-9]*$$/#. embedded usage text\n#: $<:&/'; \
+ $(xgettext-sh-prose); \
+ $(xgettext-sh-std); \
+ } | $(pofmt) > $@