summaryrefslogtreecommitdiff
path: root/src
diff options
context:
space:
mode:
authorLuke Shumaker <LukeShu@sbcglobal.net>2013-05-31 19:33:48 -0600
committerLuke Shumaker <LukeShu@sbcglobal.net>2013-06-05 19:53:19 -0600
commit06f0fa6d1dfee7b8d9248d75b36919fae10f4b10 (patch)
tree7c588a42b8a91bc6b27e4ce6a320811d1e02564a /src
parent717e15b52f8081e14f24fac9c047388d699d2673 (diff)
librediff: fix (even if it is stupid)
Diffstat (limited to 'src')
-rwxr-xr-xsrc/librediff18
1 files changed, 11 insertions, 7 deletions
diff --git a/src/librediff b/src/librediff
index e8824aa..f84d037 100755
--- a/src/librediff
+++ b/src/librediff
@@ -20,7 +20,9 @@
# You should have received a copy of the GNU General Public License
# along with Parabola. If not, see <http://www.gnu.org/licenses/>.
-. /etc/libretools.conf
+. $(librelib conf.sh)
+load_files libretools
+check_vars libretools PATCHDIR
cmd=${0##*/}
@@ -43,12 +45,14 @@ main() {
then
error "Build scripts not found for ${package}(-libre)"
else
-
- . ./${package}-libre/PKGBUILD
- [[ -z ${pkgbase} ]] && pkgbase=${pkgname}
-
- # Generate a diff file, no -r since we don't want to patch src/ nor pkg/
- diff -auN ${package} ${package}-libre > $PATCHDIR/${pkgbase}-${pkgver}-${pkgrel}.patch
+ (
+ . ./${package}-libre/PKGBUILD
+ [[ -z ${pkgbase} ]] && pkgbase=${pkgname}
+
+ # Generate a diff file, no -r since we don't want to patch src/ nor pkg/
+ diff -auN ${package} ${package}-libre > $PATCHDIR/${pkgbase}-${pkgver}-${pkgrel}.patch
+ )
+ fi
done
exit 0