summaryrefslogtreecommitdiff
path: root/src
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@sbcglobal.net>2014-07-01 13:32:09 -0400
committerLuke Shumaker <lukeshu@sbcglobal.net>2014-07-01 13:32:09 -0400
commit5ea8350852907eed656d8af7e81e10618214ddf3 (patch)
tree843ed7d70e8629b1b9e268c18b0968ecfa99b889 /src
parent12d210957879a4fb70e1df1a6ae3af4be118fa71 (diff)
grep for simple-to-fix issues with loading PKGBUILDs
Diffstat (limited to 'src')
-rwxr-xr-xsrc/xbs-abslibre/helper-abslibre4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/xbs-abslibre/helper-abslibre b/src/xbs-abslibre/helper-abslibre
index ce21b99..2e5ed27 100755
--- a/src/xbs-abslibre/helper-abslibre
+++ b/src/xbs-abslibre/helper-abslibre
@@ -37,7 +37,7 @@ release() {
. $(librelib conf)
load_files libretools
check_vars libretools WORKDIR ABSLIBREDEST || return 1
- local pkgbase="$(load_PKGBUILD; printf '%s\n' "${pkgbase:-${pkgname}}")"
+ local pkgbase="$(load_PKGBUILD >/dev/null; printf '%s\n' "${pkgbase:-${pkgname}}")"
local pkgdir="${ABSLIBREDEST}/${arch}/${repo}/${pkgbase}"
lock 9 "${ABSLIBREDEST}/${arch}.lock" "Waiting for a lock on the ABSLibre release directory for ${arch}"
@@ -65,7 +65,7 @@ unrelease() {
load_files libretools
check_vars libretools ABSLIBREDEST || return 1
- local pkgbase="$(load_PKGBUILD; printf '%s\n' "${pkgbase:-${pkgname}}")"
+ local pkgbase="$(load_PKGBUILD >/dev/null; printf '%s\n' "${pkgbase:-${pkgname}}")"
local pkgdir="${ABSLIBREDEST}/${arch}/${repo}/${pkgbase}"
lock 9 "${ABSLIBREDEST}/${arch}.lock" "Waiting for a lock on the ABSLibre release directory for ${arch}"