summaryrefslogtreecommitdiff
path: root/src
diff options
context:
space:
mode:
authorbill-auger <mr.j.spam.me@gmail.com>2022-08-28 21:54:55 -0400
committerbill-auger <mr.j.spam.me@gmail.com>2022-08-29 10:27:59 -0400
commit61dc063f6206557512c942500e99fcf90898211c (patch)
treeb61e602d055af539107dd9c9641d674a5113f352 /src
parenta07191f94b0b069b5c69da20d9935713d2455605 (diff)
temp fix - host<->chroot glibc mismatch
Diffstat (limited to 'src')
-rw-r--r--src/chroot-tools/chcleanup.in9
1 files changed, 9 insertions, 0 deletions
diff --git a/src/chroot-tools/chcleanup.in b/src/chroot-tools/chcleanup.in
index 2cb39af..1d77ede 100644
--- a/src/chroot-tools/chcleanup.in
+++ b/src/chroot-tools/chcleanup.in
@@ -75,6 +75,15 @@ WHITELIST_PKGS=() # DEBUG: normally empty - optional packages, possibly insane
fakeroot_pkg=fakeroot$( [[ "$(uname -m)" == 'armv7l' ]] && echo '-tcp' )
CHROOTPKG=( ${CHROOTPKG[*]/fakeroot/${fakeroot_pkg}/} )
+# FIXME: host<->chroot glibc mismatch
+WHITELIST_PKGS+=( glibc-linux4 ) # BR #3038
+# $ wget https://repo.archlinuxcn.org/x86_64/glibc-linux4-2.33-4-x86_64.pkg.tar.zst.sig
+# $ wget https://repo.archlinuxcn.org/x86_64/glibc-linux4-2.33-4-x86_64.pkg.tar.zst
+# $ pacman-key --verify glibc-linux4-2.33-4-x86_64.pkg.tar.zst.sig
+# $ sudo librechroot -n autobuilder install-file glibc-linux4-2.33-4-x86_64.pkg.tar.zst
+# $ sudo cp glibc-linux4-2.33-4-x86_64.pkg.tar.zst* /var/lib/archbuild/autobuilder/bill-auger/
+# $ sudo librechroot -n autobuilder enter
+
# If we're running makepkg
if [[ -f ./PKGBUILD ]]; then
if [[ ! -f ./.SRCINFO || ./PKGBUILD -nt ./.SRCINFO ]]; then