summaryrefslogtreecommitdiff
path: root/src
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@sbcglobal.net>2014-07-02 16:41:57 -0400
committerLuke Shumaker <lukeshu@sbcglobal.net>2014-07-02 16:41:57 -0400
commit800bc090025b154ed8b8909d1f52ecd937bc9d32 (patch)
treeabf0fe9cf0c86b33c2404afd679a16326a2c9a3e /src
parent938a711aae6ecf871f37dda71b8e55bebbb6eba8 (diff)
Some grammar fixes too.
Diffstat (limited to 'src')
-rwxr-xr-xsrc/abslibre-tools/librerelease2
-rw-r--r--src/librefetch/librefetch.8.ronn22
2 files changed, 12 insertions, 12 deletions
diff --git a/src/abslibre-tools/librerelease b/src/abslibre-tools/librerelease
index d89ac21..bf69a8b 100755
--- a/src/abslibre-tools/librerelease
+++ b/src/abslibre-tools/librerelease
@@ -124,7 +124,7 @@ usage() {
print "Usage: %s [OPTIONS]" "${0##*/}"
echo
prose 'This script uploads packages on $WORKDIR/staging
- to parabola server.'
+ to the Parabola server.'
echo
print "Options:"
flag '-c' 'Clean; delete packages in $WORKDIR/staging'
diff --git a/src/librefetch/librefetch.8.ronn b/src/librefetch/librefetch.8.ronn
index 3ed462d..c43a575 100644
--- a/src/librefetch/librefetch.8.ronn
+++ b/src/librefetch/librefetch.8.ronn
@@ -76,21 +76,21 @@ whitelisted locations.
## CREATE MODE
-The principle of `create` mode is that a special `PKGBUILD(5)`, called
-`SRCBUILD(5)`, that installs source files to <$pkgdir>, and the
-resulting "package" is then used as a source tarball. The `SRCBUILD`
-exists in the same directory as the `PKGBUILD`. It can be created
-manually, or generated on-the-fly from the `PKGBUILD`. Extra steps
-are taken to ensure that as long as the same directory contents go in,
-an identical tarball will come out--the checksum of the file should
-not change based on when it is built or who builds it.
+The principle of `create` mode is that a special `PKGBUILD(5)` (called
+`SRCBUILD(5)`) installs source files to <$pkgdir>, and the resulting
+"package" is then used as a source tarball. The `SRCBUILD` exists in
+the same directory as the `PKGBUILD`. It can be created manually, or
+generated on-the-fly from the `PKGBUILD`. Extra steps are taken to
+ensure that as long as the same directory contents go in, an identical
+tarball will come out--the checksum of the file should not change
+based on when it is built or who builds it.
The `SRCBUILD` is either created, or sanitized if it already exists,
then fed to a modified version of `makepkg(8)`.
-The purpose of the modified `makepkg` is so that the resulting tarball
-doesn't contain package metadata, doesn't end with a .pkg file
-extension, and always produces an identicle tarball.
+The reason `makepkg` must be modified is that we need the resulting
+tarball to be deterministic (as well as not containing package
+metadata).
When this documentation speaks of a file being modified, it is a
temporary copy of the file that is modified, your original file will