summaryrefslogtreecommitdiff
path: root/src
diff options
context:
space:
mode:
authorLuke Shumaker <LukeShu@sbcglobal.net>2014-02-02 20:22:24 -0500
committerLuke Shumaker <LukeShu@sbcglobal.net>2014-02-02 20:22:24 -0500
commit804e5e1093c3aa8258bf9f8c97ff661cdf8407f1 (patch)
tree3da603d7b28eeb3ba6da52fc857272152c705dfb /src
parente4ccc15cccf46e6265347f4fdee598b0561c4c74 (diff)
Makefiles: use .DELETE_ON_ERROR:
Diffstat (limited to 'src')
-rw-r--r--src/chroot-tools/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/src/chroot-tools/Makefile b/src/chroot-tools/Makefile
index 4ecff51..97ca688 100644
--- a/src/chroot-tools/Makefile
+++ b/src/chroot-tools/Makefile
@@ -27,19 +27,19 @@ makechrootpkg.sh.in: %.sh.in: $(devtoolsdir)/%.in
cp $< $@
makechrootpkg.sh.ugly: %.ugly: %.in %.patch Makefile
cp $*.in $@
- @echo 'PATCH $@ $*.patch'; patch $@ $*.patch || { rm -f -- '$@'; false; }
+ @echo 'PATCH $@ $*.patch'; patch $@ $*.patch
makechrootpkg.sh: %: %.ugly Makefile
- @echo 'EDIT < $< > $@'; $(edit) <'$<' >'$@' || { rm -f -- '$@'; false; }
- @echo 'INDENT $@'; $(call indent,$@) || { rm -f -- '$@'; false; }
+ @echo 'EDIT < $< > $@'; $(edit) <'$<' >'$@'
+ @echo 'INDENT $@'; $(call indent,$@)
mkarchroot: mkarchroot.in Makefile
@echo '< $< M4_EDIT | SED > $@'
- @<'$<' $(edit) | sed -e 's|arch-nspawn|$$(librelib chroot/&)|' -e 's/pacstrap/env -i &/' >'$@' || { rm -f -- '$@'; false; }
- @echo 'CHMOD $<'; chmod 755 "$@" || { rm -f -- '$@'; false; }
+ @<'$<' $(edit) | sed -e 's|arch-nspawn|$$(librelib chroot/&)|' -e 's/pacstrap/env -i &/' >'$@'
+ @echo 'CHMOD $<'; chmod 755 "$@"
archroot: %: %.in Makefile
@echo "GEN $@"
- @$(edit) <"$<" >"$@" || { rm -f -- '$@'; false; }
- @chmod 755 "$@" || { rm -f -- '$@'; false; }
+ @$(edit) <"$<" >"$@"
+ @chmod 755 "$@"
distcc-tool.pot: xgettext-keywords-sh+=--keyword=errusage