summaryrefslogtreecommitdiff
path: root/src
diff options
context:
space:
mode:
authorLuke Shumaker <LukeShu@sbcglobal.net>2013-04-25 15:54:44 -0400
committerLuke Shumaker <LukeShu@sbcglobal.net>2013-04-25 15:57:27 -0400
commitbf2e3833c4158c8ec94e6af621f7d50d11353957 (patch)
treef2195c4934b543664871295f3a37ffe5b7925dcb /src
parentdebfb3821f4c40f9a9625b76b211c8c6b50e0aac (diff)
beta 4 of librefetch
Diffstat (limited to 'src')
-rwxr-xr-xsrc/librefetch/librefetch11
1 files changed, 8 insertions, 3 deletions
diff --git a/src/librefetch/librefetch b/src/librefetch/librefetch
index 70ff184..2412db8 100755
--- a/src/librefetch/librefetch
+++ b/src/librefetch/librefetch
@@ -28,26 +28,31 @@ trap cleanup EXIT
cmd=${0##*/}
usage() {
print "Usage: %s [options] <source-url> <output-file>" "$cmd"
- print "Usage: %s [options] -g" "$cmd"
+ print "Usage: %s -[g|V|h]" "$cmd"
print "Downloads or creates a liberated source tarball."
echo
print "The default build script is 'PKGBUILD', or 'SRCBUILD' if it exists."
echo
print "Unrecognized options are passed straight to makepkg."
echo
+ print "Example usage:"
+ print ' $ %s libre://mypackage-1.0.tar.gz $SRCDEST/mypackage-1.0.tar.gz.part' "$cmd"
+ echo
print "Options:"
+ print " Settings:"
print " -C Force create mode (don't download)"
print " -D Force download mode (don't create)"
print " -p <file> Use an alternate build script (instead of 'PKGBUILD')"
print " If an SRCBUILD exists in the same directory, it is used"
print " instead"
+ print " Alternate modes:"
print " -g, --geninteg Generage integrity checks for source files"
print " -V, --version Show version information"
print " -h, --help Show this message"
}
version() {
- print "librefetch (libretools) beta 3"
+ print "librefetch (libretools) beta 4"
echo
print "Copyright (C) 2013 Luke Shumaksr <lukeshu@sbcglobal.net>"
print "This is free software; see the source for copying conditions."
@@ -58,7 +63,7 @@ main() {
BUILDFILE="$(readlink -m PKGBUILD)"
makepkg_opts=()
extra_opts=()
- mode=create # download-create
+ mode=download-create
parse_options "$@"
local startdir=$PWD