summaryrefslogtreecommitdiff
path: root/src
diff options
context:
space:
mode:
authorLuke Shumaker <LukeShu@sbcglobal.net>2013-09-23 20:34:07 -0400
committerLuke Shumaker <LukeShu@sbcglobal.net>2013-09-29 18:48:52 -0400
commitde03c74f12e95d905cc787e3814270a773d01bea (patch)
tree58e3ea40e3aa7895971fa70c991b87bf5bbde205 /src
parentbb9a2dd0cf631551d86c7471960e90fc236354d0 (diff)
fullpkg-find: fiddle with some of the quoting, it was tripping up xgettext
Diffstat (limited to 'src')
-rwxr-xr-xsrc/fullpkg/fullpkg-find2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/fullpkg/fullpkg-find b/src/fullpkg/fullpkg-find
index fd6a107..007c53c 100755
--- a/src/fullpkg/fullpkg-find
+++ b/src/fullpkg/fullpkg-find
@@ -78,7 +78,7 @@ copy_files() {
for i in 'changelog' 'install'; do
while read -r file; do
# evaluate any bash variables used
- eval file=\"$(sed 's/^\(['\''"]\)\(.*\)\1$/\2/' <<< "$file")\"
+ eval file=\"$(sed "s/^\\(['\"]\\)\\(.*\\)\\1\$/\\2/" <<< "$file")\"
[[ -f $file ]] && cp "$file" "$copydir"
done < <(sed -n "s/^[[:space:]]*$i=//p" PKGBUILD)
done