summaryrefslogtreecommitdiff
path: root/src
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@sbcglobal.net>2014-07-02 16:39:41 -0400
committerLuke Shumaker <lukeshu@sbcglobal.net>2014-07-02 16:39:41 -0400
commit938a711aae6ecf871f37dda71b8e55bebbb6eba8 (patch)
treef5d8c4c5f38295ea948a612c408da2bc06f2af74 /src
parent7dd14c9d6869c9d129280358e44edc43eb2ca9bf (diff)
spell-check :/
Diffstat (limited to 'src')
-rwxr-xr-xsrc/abslibre-tools/libredbdiff2
-rwxr-xr-xsrc/abslibre-tools/librerelease2
-rwxr-xr-xsrc/fullpkg/fullpkg-build6
-rwxr-xr-xsrc/fullpkg/fullpkg-find2
-rwxr-xr-xsrc/gitget/gitget4
-rwxr-xr-xsrc/gitget/libregit2
-rwxr-xr-xsrc/is_built2
-rw-r--r--src/lib/common.sh.3.ronn2
-rw-r--r--src/lib/libreblacklist.1.ronn2
-rw-r--r--src/lib/librelib.1.ronn2
-rw-r--r--src/lib/librelib.7.ronn6
-rw-r--r--src/lib/libremessages.1.ronn8
-rwxr-xr-xsrc/librefetch/librefetch2
-rw-r--r--src/librefetch/librefetch.8.ronn20
-rw-r--r--src/librefetch/librefetch.conf.5.ronn2
-rw-r--r--src/libretools.conf4
-rwxr-xr-xsrc/xbs-abs/helper-abs2
-rwxr-xr-xsrc/xbs/xbs2
18 files changed, 36 insertions, 36 deletions
diff --git a/src/abslibre-tools/libredbdiff b/src/abslibre-tools/libredbdiff
index d2d2505..098bade 100755
--- a/src/abslibre-tools/libredbdiff
+++ b/src/abslibre-tools/libredbdiff
@@ -108,7 +108,7 @@ usage() {
print "Usage: %q [-n|-h]" "$cmd"
print 'Show [libre] packages that need to be updated from Arch repositories.'
echo
- prose "The default mode of operation is to download/update all nescessary
+ prose "The default mode of operation is to download/update all necessary
files for comparison, but not compare them. Specify the \`-n\`
flag to not download anything, but to compare already downloaded
files."
diff --git a/src/abslibre-tools/librerelease b/src/abslibre-tools/librerelease
index fc1ab11..d89ac21 100755
--- a/src/abslibre-tools/librerelease
+++ b/src/abslibre-tools/librerelease
@@ -123,7 +123,7 @@ clean_files() {
usage() {
print "Usage: %s [OPTIONS]" "${0##*/}"
echo
- prose 'This script uploads packages on $WORKDIR/stagging
+ prose 'This script uploads packages on $WORKDIR/staging
to parabola server.'
echo
print "Options:"
diff --git a/src/fullpkg/fullpkg-build b/src/fullpkg/fullpkg-build
index 06d0d50..a31025e 100755
--- a/src/fullpkg/fullpkg-build
+++ b/src/fullpkg/fullpkg-build
@@ -62,7 +62,7 @@ remove_buildorder() {
return $?
}
-succesfull_build() {
+successful_build() {
if [[ "$RUN" != "$FULLBUILDCMD" ]]; then
return 0 # Custom command or download sources
@@ -106,7 +106,7 @@ __build() {
case $r in
- 0) succesfull_build ;;
+ 0) successful_build ;;
*) error "There were errors while trying to build the package."
echo "failed:$(basename $PWD)" >>$build_dir/log
@@ -152,7 +152,7 @@ usage() {
prose "If no BUILD_DIR is specified, it uses the current directory."
echo
print "Options:"
- flag "-c" "Clean BUILD_DIR on succesfull build"
+ flag "-c" "Clean BUILD_DIR on successful build"
flag "-N" "Don't check for freedom issues." #Also made by fullpkg-find
flag "-r $(_ CMD)" "Use CMD instead of \${FULLBUILDCMD}"
flag "-g" "Get sources for building packages on BUILD_DIR"
diff --git a/src/fullpkg/fullpkg-find b/src/fullpkg/fullpkg-find
index c12888a..af30ed9 100755
--- a/src/fullpkg/fullpkg-find
+++ b/src/fullpkg/fullpkg-find
@@ -197,7 +197,7 @@ while getopts 'hA:l:cmn' arg; do
done
if [[ ! -r PKGBUILD ]]; then
- error "This directory doesnt contain a PKGBUILD"
+ error "This directory doesn't contain a PKGBUILD"
usage
exit 1
fi
diff --git a/src/gitget/gitget b/src/gitget/gitget
index fe5d46b..ffae2a9 100755
--- a/src/gitget/gitget
+++ b/src/gitget/gitget
@@ -155,11 +155,11 @@ usage() {
prose 'For a checkout, the tree to checkout is specified by appending
`#ANYTHING=TREE-ISH` to the URL. For example, `#branch=stable`,
or `#tag=v12.3`. Whatever is on the left side of the equal sign
- is ignored, this is for compatability with `makepkg` source
+ is ignored, this is for compatibility with `makepkg` source
URLs.'
echo
prose "The URL may be prefixed with \`git+\`. This is also for
- compatability with \`makepkg\` source URLs."
+ compatibility with \`makepkg\` source URLs."
echo
prose "It does safety checks, figures out whether to clone or pull, and
other helpful things. This exists because the same
diff --git a/src/gitget/libregit b/src/gitget/libregit
index 41aefc3..f1775c1 100755
--- a/src/gitget/libregit
+++ b/src/gitget/libregit
@@ -21,7 +21,7 @@
usage() {
print 'Usage: %s REPO REF DIR' "${0##*/}"
- print 'A compatability wrapper around `gitget checkout`'
+ print 'A compatibility wrapper around `gitget checkout`'
echo
prose "This exists because gitget used to be called libregit, and took
the arguments in this format, and I'm sure there are a few
diff --git a/src/is_built b/src/is_built
index 67c0d8d..29b2744 100755
--- a/src/is_built
+++ b/src/is_built
@@ -26,7 +26,7 @@ usage() {
print "Usage: %s [-h] PKGNAME [PKGVER]" "${0##*/}" "${0##*/}"
print 'Detect iv a given package (version) is already in the repos'
echo
- prose "If a version is specified, it assumedx that you want a greater or
+ prose "If a version is specified, it assumed that you want a greater or
equal version."
echo
prose "Example usage:"
diff --git a/src/lib/common.sh.3.ronn b/src/lib/common.sh.3.ronn
index 2ec113c..f2bab7a 100644
--- a/src/lib/common.sh.3.ronn
+++ b/src/lib/common.sh.3.ronn
@@ -1,7 +1,7 @@
common.sh -- common Bash routines from devtools
===============================================
-## SYNPOSIS
+## SYNOPSIS
`. $(librelib common)`
diff --git a/src/lib/libreblacklist.1.ronn b/src/lib/libreblacklist.1.ronn
index e44aa8d..550ace8 100644
--- a/src/lib/libreblacklist.1.ronn
+++ b/src/lib/libreblacklist.1.ronn
@@ -1,7 +1,7 @@
libreblacklist(1) -- Tools for working with the your-freedom blacklist
======================================================================
-## SYNPOSIS
+## SYNOPSIS
`. $(librelib blacklist)`<br>
`. libreblacklist`<br>
diff --git a/src/lib/librelib.1.ronn b/src/lib/librelib.1.ronn
index 42d8f15..b3fc35e 100644
--- a/src/lib/librelib.1.ronn
+++ b/src/lib/librelib.1.ronn
@@ -6,7 +6,7 @@ librelib(1) -- finds a Bash library file
`. $(librelib LIBRARY)`<br>
`librelib -h`
-## DESRIPTION
+## DESCRIPTION
`librelib` is a program to find a Bash(1) library file at run-time.
This way, the path does not need to be hard-coded into the
diff --git a/src/lib/librelib.7.ronn b/src/lib/librelib.7.ronn
index e030f6a..3116462 100644
--- a/src/lib/librelib.7.ronn
+++ b/src/lib/librelib.7.ronn
@@ -3,7 +3,7 @@ librelib(7) -- Suite of Bash libraries
## SYNOPSIS
-Overview ot the librelib Bash library suite.
+Overview of the librelib Bash library suite.
## DESCRIPTION
@@ -19,8 +19,8 @@ libraries installed in `/usr/lib/libretools`. Think of it as a sort
of dynamic-linker.
The 'core' of librelib are the libraries installed in
-`/usr/lib/libretools`. These are `Bash`(1) libaries that may be sourced in
-Bash programs.
+`/usr/lib/libretools`. These are `Bash`(1) libraries that may be
+sourced in Bash programs.
Some of these libraries also make sense as stand-alone programs, where
if they are invoked directly, the first argument is the library
diff --git a/src/lib/libremessages.1.ronn b/src/lib/libremessages.1.ronn
index daafd2f..b3cf13d 100644
--- a/src/lib/libremessages.1.ronn
+++ b/src/lib/libremessages.1.ronn
@@ -76,7 +76,7 @@ Unless otherwise noted, these do not implicitly call `gettext`.
### PROSE ROUTINES
-These routines print to standard output, ande are useful for printing
+These routines print to standard output, and are useful for printing
word-wrapped prose.
For each of these, <MESSAGE> is fed through `gettext` automatically.
@@ -169,7 +169,7 @@ these, you could end up deleting a lot of someone's work.
### LOCKFILE ROUTINES
* `lock` <FD> <LOCKFILE> <MESSAGE> [<MSG_ARGS>...]:
- Opens (creating if nescessary) the file <LOCKFILE> with file
+ Opens (creating if necessary) the file <LOCKFILE> with file
descriptor <FD> in the current process, and gets an exclusive
lock on it. If another program already has a lock on the file,
and this program needs to wait for the lock to be release, then
@@ -188,11 +188,11 @@ these, you could end up deleting a lot of someone's work.
These routines relate to `makepkg`(8).
* `find_cached_package` <PKGNAME> <PKGVER>[-<PKGREL] <ARCH>:
- Searches for a localy built copy of the specified package, in
+ Searches for a locally built copy of the specified package, in
<PKGDEST> and the current working directory. If <PKGREL> is not
specified, any value will match. If multiple matching files are
found (not counting duplicate links), then an error is printed to
- stderr and nothing is prented to stdout.
+ stderr and nothing is printed to stdout.
* `get_full_version` [<PKGNAME>]:
Inspects variables that are set, and prints the full version
diff --git a/src/librefetch/librefetch b/src/librefetch/librefetch
index 1d8b152..1c793aa 100755
--- a/src/librefetch/librefetch
+++ b/src/librefetch/librefetch
@@ -67,7 +67,7 @@ usage() {
'PKGBUILD') If an SRCBUILD exists in the same
directory, it is used instead"
print " Alternate modes:"
- flag "-g, --geninteg" "Generage integrity checks for source files"
+ flag "-g, --geninteg" "Generate integrity checks for source files"
flag "-S, --srcbuild" "Print the effective build script (SRCBUILD)"
flag "-M, --makepkg" "Print the effective makepkg script"
flag "-h, --help" "Show this message"
diff --git a/src/librefetch/librefetch.8.ronn b/src/librefetch/librefetch.8.ronn
index 6ee3ce8..3ed462d 100644
--- a/src/librefetch/librefetch.8.ronn
+++ b/src/librefetch/librefetch.8.ronn
@@ -11,7 +11,7 @@ librefetch(8) -- downloads or creates a liberated source tarball
`librefetch` is a program to streamline creation of custom source
tarballs for `PKGBUILD(5)` files.
-If a URL mentioned in the <source> array in a `PKGUILD` is in a
+If a URL mentioned in the <source> array in a `PKGBUILD` is in a
location that Parabola uploads "custom" source tarballs to (or
configured locations), and no file is at that URL, librefetch will
automatically create it for you.
@@ -23,8 +23,8 @@ Because of this, it is almost never necessary to call `librefetch`
manually.
The post-install script also configures `librefetch` as the download
-agent for `libre://` URLs, for compatability with PKGBUILDs that used
-a previous version of librefetch.
+agent for `libre://` URLs, for compatibility with `PKGBUILD` files
+that used a previous version of librefetch.
There are 5 modes:
@@ -51,7 +51,7 @@ fails, it may choose to try `create` mode.
script.
* `-M` | `--makepkg`: Use `makepkg` mode: print the effective makepkg
script.
- * `-h` | `--help`: Use `help` mode: Show useage information.
+ * `-h` | `--help`: Use `help` mode: Show usage information.
Other options, if they are documented in `makepkg -h`, are passed to
the modified copy of makepkg created during `create` mode.
@@ -60,8 +60,8 @@ the modified copy of makepkg created during `create` mode.
If <SOURCE-URL> begins with the string `libre://`, it is replaced with
the first value in <MIRRORS>, as configured in `librefetch.conf(5)`;
-this is for compatability with PKGBUILDs that used a previous version
-of librefetch.
+this is for compatibility with `PKGBUILD` files that used a previous
+version of librefetch.
It uses <DOWNLOADER>, as configured in `librefetch.conf` to attempt to
download the source tarball from that URL. If that fails, and
@@ -126,7 +126,7 @@ this method, the `SRCBUILD` must be deleted (or renamed) for this to
work.
The dynamically created `SRCBUILD` is created by copying `PKGBUILD` to
-a temorary file, then re-setting variables and re-defining functions.
+a temporary file, then re-setting variables and re-defining functions.
Following is a table of the translations.
Variables
@@ -151,19 +151,19 @@ In summary:
* Set <mksource=()> and <mkmd5sums=()> to act as <source=()> and
<md5sums=()>, respectively.
* Declare a `mksource()` function to make modifications to the
- source, if nescessary.
+ source, if necessary.
Other changes:
* <pkgname> is set to <pkgbase>, or the first element of the
- <pkgname> array (the effect is that split packaging is turnes
+ <pkgname> array (the effect is that split packaging is turned
off).
* <options=()> is set have `makepkg` avoid making changes to
<$pkgdir>. The exact change is:
options=(!strip docs libtool staticlibs emptydirs !zipman purge !upx)
- * <PURGE_TARGETS=()> has vcs directories added to it:
+ * <PURGE_TARGETS=()> has VCS directories added to it:
PURGE_TARGETS=(.bzr/ .cvs/ .git/ .hg/ .svn/ .makepkg/)
diff --git a/src/librefetch/librefetch.conf.5.ronn b/src/librefetch/librefetch.conf.5.ronn
index 6158104..29df4d2 100644
--- a/src/librefetch/librefetch.conf.5.ronn
+++ b/src/librefetch/librefetch.conf.5.ronn
@@ -13,7 +13,7 @@ several places it looks for the file are:
* `/etc/libretools.d/librefetch.conf`
* `$XDG_CONFIG_HOME/libretools/librefetch.conf`
-The later files take precidence over earlier files, but earlier files
+The later files take precedence over earlier files, but earlier files
are loaded, so that later files only need to set the values they want
to override.
diff --git a/src/libretools.conf b/src/libretools.conf
index 67810d2..9e5b83b 100644
--- a/src/libretools.conf
+++ b/src/libretools.conf
@@ -37,7 +37,7 @@ ABSLIBREDEST="$WORKDIR/staging/abslibre"
################################################################################
## Where to upload packages to
-# '/staging/' is appended; this is for compatability with previous versions.
+# '/staging/' is appended; this is for compatibility with previous versions.
REPODEST=repo@repo:/srv/http/repo/staging/$LIBREUSER
## Assumes something similar in your .ssh/config:
# Host repo
@@ -72,7 +72,7 @@ FULLBUILDCMD="sudo libremakepkg"
#FULLBUILDCMD="makepkg -sL --noconfirm"
# Locally release the package or any other action after running FULLBUILDCMD
-# succesfully. When run, it is given a repository name as a single argument.
+# successfully. When run, it is given a repository name as a single argument.
HOOKLOCALRELEASE="librestage"
#HOOKLOCALRELEASE="mipsrelease"
diff --git a/src/xbs-abs/helper-abs b/src/xbs-abs/helper-abs
index 7ce7b51..88f572a 100755
--- a/src/xbs-abs/helper-abs
+++ b/src/xbs-abs/helper-abs
@@ -85,7 +85,7 @@ download() {
arch_svn -q up "$SVNDIR/$svnrepo"/*
else
# checkout non-recursive, then lazy load
- # nescessary because:
+ # necessary because:
# > DO NOT CHECK OUT THE ENTIRE SVN REPO. Your address
# > may be blocked.
arch_svn -q checkout -N "$svnurl" "$SVNDIR/$svnrepo"
diff --git a/src/xbs/xbs b/src/xbs/xbs
index 34d8945..ea762fb 100755
--- a/src/xbs/xbs
+++ b/src/xbs/xbs
@@ -38,7 +38,7 @@ usage() {
bullet '/etc/xbs.conf'
bullet '${XDG_CONFIG_HOME}/xbs.conf'
bullet 'with the `-b` flag'
- prose 'Later items take precidence over earlier ones.'
+ prose 'Later items take precedence over earlier ones.'
echo
prose 'It looks for a helper programs named helper-${BUILDSYSTEM}, in
the directory `%q` by default, but this directory can be changed