summaryrefslogtreecommitdiff
path: root/src
diff options
context:
space:
mode:
authorLuke Shumaker <LukeShu@sbcglobal.net>2013-06-05 19:47:33 -0600
committerLuke Shumaker <LukeShu@sbcglobal.net>2013-06-05 19:50:49 -0600
commit717e15b52f8081e14f24fac9c047388d699d2673 (patch)
treeb57460eee969eb15cbf7530a85d948fa980bc41a /src
parent4f340d30b75b9ae5344bc2ab18a897ff37f89b03 (diff)
treepkg: make compound if statements more readable
Diffstat (limited to 'src')
-rwxr-xr-xsrc/treepkg4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/treepkg b/src/treepkg
index 1453f41..519dee5 100755
--- a/src/treepkg
+++ b/src/treepkg
@@ -128,7 +128,7 @@ CLEANUP=${C:-true}
# Skip BUILDORDER creation and build anything on BUILDDIR
BUILDNOW=${N:-false}
-if [ ! -z "${1}" -a ${DEPTH} -eq 0 ]; then
+if [[ ! -z $1 ]] && [[ $DEPTH -eq 0 ]]; then
BUILDNOW=true
fi
@@ -171,7 +171,7 @@ if ! ${BUILDNOW}; then
# Ask toru where's a PKGBUILD
depdir="$(toru-where ${_dep})"
- if [ -z "${depdir}" -o ! -d "${depdir}" ]; then
+ if [[ -z ${depdir} ]] || [[ ! -d ${depdir} ]]; then
# We specify the pkgname because we can't source the dep PKGBUILD
# Normally 'any' packages are missing from our work ABS
add_order "missing" "${_dep}"