summaryrefslogtreecommitdiff
path: root/src
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@lukeshu.com>2017-04-20 22:39:20 -0400
committerLuke Shumaker <lukeshu@lukeshu.com>2017-04-20 23:00:21 -0400
commit23213bda24af601acbbea5731246a055680b48d0 (patch)
tree09fe7c18f2d5cecca569658c4968357274392769 /src
parentd958a33c1f0e11b770481a9188cbf75cc3bfd0a5 (diff)
Variables inside of $((...)) don't need a $ in front of them.
These were found with the help of shellcheck.
Diffstat (limited to 'src')
-rwxr-xr-xsrc/abslibre-tools/libredbdiff2
-rwxr-xr-xsrc/abslibre-tools/librerelease2
-rwxr-xr-xsrc/aur4
-rwxr-xr-xsrc/chroot-tools/librechroot2
-rwxr-xr-xsrc/chroot-tools/libremakepkg2
-rwxr-xr-xsrc/gitget/gitget2
-rwxr-xr-xsrc/pkgbuild-check-nonfree20
-rwxr-xr-xsrc/pkgbuild-summarize-nonfree4
-rwxr-xr-xsrc/xbs/xbs2
9 files changed, 20 insertions, 20 deletions
diff --git a/src/abslibre-tools/libredbdiff b/src/abslibre-tools/libredbdiff
index 24d285e..2617323 100755
--- a/src/abslibre-tools/libredbdiff
+++ b/src/abslibre-tools/libredbdiff
@@ -47,7 +47,7 @@ cmd="${0##*/}"
arch_packages_tmp="/tmp/${cmd}.arch-packages"
parabola_packages_tmp="/tmp/${cmd}.parabola-packages"
-field_pkgname_total="$((${field_pkgname_parabola} + ${field_pkgname_arch}))"
+field_pkgname_total="$((field_pkgname_parabola + field_pkgname_arch))"
printf_format="%s %-${field_pkgname_parabola}s%-${field_pkgname_arch}s %s | %s\n"
printf_format_noarch="%s %-${field_pkgname_total}s %s\n"
diff --git a/src/abslibre-tools/librerelease b/src/abslibre-tools/librerelease
index e7f8139..6d5651d 100755
--- a/src/abslibre-tools/librerelease
+++ b/src/abslibre-tools/librerelease
@@ -154,7 +154,7 @@ main() {
*) usage >&2; return 1 ;;
esac
done
- shift $(($OPTIND - 1))
+ shift $((OPTIND - 1))
if [[ $# != 0 ]]; then
usage >&2
return 1
diff --git a/src/aur b/src/aur
index f904a16..4dc7a99 100755
--- a/src/aur
+++ b/src/aur
@@ -74,7 +74,7 @@ main() {
local url="https://aur.archlinux.org/packages/${pkg:0:2}/$pkg/$pkg.tar.gz"
set -o pipefail
if ! wget -O- -q "$url" | bsdtar xf -; then
- ret=$(($ret|2))
+ ret=$((ret|2))
error "Couldn't get %s" "$pkg"
continue
fi
@@ -138,7 +138,7 @@ main() {
if [[ ${#missing_deps[*]} -gt 0 ]]; then
msg "Retrieving missing deps: %s" "${missing_deps[*]}"
"$0" "${missing_deps[@]}"
- ret=$(($ret|$?))
+ ret=$((ret|$?))
fi
return $ret;
}
diff --git a/src/chroot-tools/librechroot b/src/chroot-tools/librechroot
index a1e01d0..dc242b2 100755
--- a/src/chroot-tools/librechroot
+++ b/src/chroot-tools/librechroot
@@ -317,7 +317,7 @@ main() {
*) usage >&2; return 1;;
esac
done
- shift $(($OPTIND - 1))
+ shift $((OPTIND - 1))
if [[ $# -lt 1 ]]; then
error "Must specify a command"
usage >&2
diff --git a/src/chroot-tools/libremakepkg b/src/chroot-tools/libremakepkg
index 84a7609..d74c78b 100755
--- a/src/chroot-tools/libremakepkg
+++ b/src/chroot-tools/libremakepkg
@@ -197,7 +197,7 @@ main() {
*) usage >&2; return 1;;
esac
done
- shift $(($OPTIND - 1))
+ shift $((OPTIND - 1))
if [[ $# != 0 ]]; then
error 'Extra arguments: %s' "$*"
return 1
diff --git a/src/gitget/gitget b/src/gitget/gitget
index 15a4f1b..7bdb9c9 100755
--- a/src/gitget/gitget
+++ b/src/gitget/gitget
@@ -196,7 +196,7 @@ main() {
*) usage >&2; return 1;;
esac
done
- shift $(($OPTIND - 1))
+ shift $((OPTIND - 1))
[[ $# == 3 ]] || { usage >&2; return 1; }
local mode=$1
local url=${2#git+}
diff --git a/src/pkgbuild-check-nonfree b/src/pkgbuild-check-nonfree
index d5495c7..e291dbe 100755
--- a/src/pkgbuild-check-nonfree
+++ b/src/pkgbuild-check-nonfree
@@ -81,7 +81,7 @@ main() {
*) usage >&2; return $_E_ERROR;;
esac
done
- shift $(($OPTIND - 1))
+ shift $((OPTIND - 1))
if [[ $# -lt 1 ]]; then
pkgbuilds=("`pwd`/PKGBUILD")
else
@@ -113,7 +113,7 @@ main() {
declare -i ret=0
local pkgbuild
for pkgbuild in "${pkgbuilds[@]}"; do
- pkgbuild_check "$pkgbuild" || ret=$(($ret|$?))
+ pkgbuild_check "$pkgbuild" || ret=$((ret|$?))
done
return $ret
}
@@ -250,17 +250,17 @@ pkgbuild_check() (
fi
# Check if this is blacklisted
- check_pkg "${pkgbase:-${pkgname[0]}}" || ret=$(($ret|$?))
+ check_pkg "${pkgbase:-${pkgname[0]}}" || ret=$((ret|$?))
# Check if dependencies are blacklisted
for dep in "${depends[@]}" "${makedepends[@]}" "${checkdepends[@]}" \
"${optdepends[@]%%:*}" "${mkdepends[@]}"
do
- check_dep "$dep" || ret=$(($ret|$?))
+ check_dep "$dep" || ret=$((ret|$?))
ck_deps+=("$dep")
done
# Check the licenses
for lic in "${license[@]}"; do
- check_lic "$lic" || ret=$(($ret|$?))
+ check_lic "$lic" || ret=$((ret|$?))
ck_lics+=("$lic")
done
@@ -269,7 +269,7 @@ pkgbuild_check() (
# Make sure a license is set
if [[ ${#ck_lics[@]} == 0 ]]; then
error "The license array is empty"
- ret=$(($ret|$_E_ERROR))
+ ret=$((ret|_E_ERROR))
fi
else
# Split package
@@ -282,23 +282,23 @@ pkgbuild_check() (
eval "$(pkgbuild_get_pkg_ary "$_pkgname" optdepends _optdepends)"
# Check if this is blacklisted
- check_pkg "$_pkgname" || ret=$(($ret|$?))
+ check_pkg "$_pkgname" || ret=$((ret|$?))
# Check if dependencies are blacklisted
for dep in "${_depends[@]}" "${_optdepends[@]%%:*}"; do
if ! in_array "$dep" "${ck_deps[@]}"; then
- check_dep "$dep" || ret=$(($ret|$?))
+ check_dep "$dep" || ret=$((ret|$?))
fi
done
# Check the licenses
for lic in "${_license[@]}"; do
if ! in_array "$lic" "${ck_lics[@]}"; then
- check_lic "$lic" || ret=$(($ret|$?))
+ check_lic "$lic" || ret=$((ret|$?))
fi
done
if [[ ${#_license[@]} == 0 ]]; then
error "The license array is empty"
- ret=$(($ret|$_E_ERROR))
+ ret=$((ret|_E_ERROR))
fi
done
fi
diff --git a/src/pkgbuild-summarize-nonfree b/src/pkgbuild-summarize-nonfree
index f4f10f1..a0fb538 100755
--- a/src/pkgbuild-summarize-nonfree
+++ b/src/pkgbuild-summarize-nonfree
@@ -51,7 +51,7 @@ main() {
*) usage >&2; return 1;;
esac
done
- shift $(($OPTIND - 1))
+ shift $((OPTIND - 1))
if [[ $# -ne 1 ]]; then
usage >&2
return 1
@@ -77,7 +77,7 @@ parse() {
declare -i ret=0
declare -i i
for i in 1 2 4 8 16 32; do
- if [[ $(($s & $i)) -gt 0 ]]; then
+ if [[ $((s & i)) -gt 0 ]]; then
case $i in
$_E_ERROR)
# could be anything, assume the worst
diff --git a/src/xbs/xbs b/src/xbs/xbs
index ad2fbe0..7200800 100755
--- a/src/xbs/xbs
+++ b/src/xbs/xbs
@@ -137,7 +137,7 @@ main() {
*) errusage;;
esac
done
- shift $(($OPTIND - 1))
+ shift $((OPTIND - 1))
if [[ -z $BUILDSYSTEM ]]; then
load_files xbs || return 1