summaryrefslogtreecommitdiff
path: root/src
diff options
context:
space:
mode:
authorbill-auger <mr.j.spam.me@gmail.com>2021-01-18 15:32:32 -0500
committerbill-auger <mr.j.spam.me@gmail.com>2021-01-18 15:33:04 -0500
commit740c694b7011f15145a4aef3aa5cb081715c25a4 (patch)
tree0a1ad0fc1f8de158df09672d274c1acf6d53bc0c /src
parentf7878ef7b0cbcd34b604f699e93478d2358d9919 (diff)
delete split-pkg functions from mksource temporary PKGBUILD
it was previously not possible to use mksource() in a split-package the mksource temporary PKGBUILD over-rides the package() function; but conflicting package_*() functions were left in tact
Diffstat (limited to 'src')
-rwxr-xr-xsrc/librefetch/librefetch3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/librefetch/librefetch b/src/librefetch/librefetch
index f963361..67f4491 100755
--- a/src/librefetch/librefetch
+++ b/src/librefetch/librefetch
@@ -364,6 +364,9 @@ prepare() { :; }
build() { msg "Starting mksource()"; mksource; }
check() { :; }
package() { cp -a "$srcdir"/*/ "$pkgdir/"; }
+if [[ "$(declare -p pkgname 2> /dev/null)" =~ ^"declare -a " ]]
+then for pkg in ${pkgname[*]} ; do unset package_${pkg} ; done ;
+fi
'
modified_pkgbuild() {