summaryrefslogtreecommitdiff
path: root/src
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@lukeshu.com>2017-02-19 03:07:14 -0500
committerLuke Shumaker <lukeshu@lukeshu.com>2017-04-11 13:02:27 -0400
commitccb6c1d19f1866f7e670f6b7efe404bb09a0c52b (patch)
tree433926009160784ec0739480e0c9f9db98614c72 /src
parent7a8dc72cbf3e0855057eee9d9f255eae5b889abc (diff)
Update for new devtools version
Diffstat (limited to 'src')
-rwxr-xr-xsrc/chroot-tools/libremakepkg4
-rw-r--r--src/lib/.gitignore2
-rw-r--r--src/lib/Makefile4
3 files changed, 6 insertions, 4 deletions
diff --git a/src/chroot-tools/libremakepkg b/src/chroot-tools/libremakepkg
index 7f0acfd..81764af 100755
--- a/src/chroot-tools/libremakepkg
+++ b/src/chroot-tools/libremakepkg
@@ -252,8 +252,8 @@ main() {
"Waiting for existing lock on build directory to be released"
else
librechroot_flags+=(
- -r "$PWD:/startdir_host"
- -r "$SRCDEST:/srcdest_host"
+ -w "$PWD:/startdir"
+ -w "$SRCDEST:/srcdest"
-n "$CHROOT"
-l "$copy"
)
diff --git a/src/lib/.gitignore b/src/lib/.gitignore
index 650c85f..ec4ff7a 100644
--- a/src/lib/.gitignore
+++ b/src/lib/.gitignore
@@ -1,3 +1,5 @@
common.sh
common.sh.in
+archroot.sh
+archroot.sh.in
conf.sh
diff --git a/src/lib/Makefile b/src/lib/Makefile
index 7c573de..900623d 100644
--- a/src/lib/Makefile
+++ b/src/lib/Makefile
@@ -1,8 +1,8 @@
include $(dir $(lastword $(MAKEFILE_LIST)))/../../config.mk
include $(topsrcdir)/build-aux/Makefile.head.mk
-libretools.src.devtools = common.sh.in
-libretools.out.libs += common.sh conf.sh
+libretools.src.devtools = common.sh.in archroot.sh.in
+libretools.out.libs += common.sh archroot.sh conf.sh
# Build ##############################################################