summaryrefslogtreecommitdiff
path: root/src
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@sbcglobal.net>2017-01-30 14:46:36 -0500
committerLuke Shumaker <lukeshu@sbcglobal.net>2017-01-30 18:54:01 -0500
commitdc9339b5699ee3b0d48145a1389f93e9e09d02a6 (patch)
treeed71bd691ea6e0d05d47e2bfd891c333bf5709ab /src
parent4f9203808ef9607ae27eba3cf77079bbe661fd95 (diff)
Update and tidy the build system for autothing v3.
Diffstat (limited to 'src')
l---------src/GNUmakefile1
-rw-r--r--src/Makefile6
l---------src/abslibre-tools/GNUmakefile1
l---------src/chroot-tools/GNUmakefile1
-rw-r--r--src/chroot-tools/Makefile19
-rw-r--r--src/devtools/.gitignore1
l---------src/devtools/GNUmakefile1
-rw-r--r--src/devtools/Makefile8
l---------src/gitget/GNUmakefile1
l---------src/lib/GNUmakefile1
-rw-r--r--src/lib/Makefile8
l---------src/librefetch/GNUmakefile1
-rw-r--r--src/librefetch/Makefile14
l---------src/toru/GNUmakefile1
l---------src/xbs-abs/GNUmakefile1
-rw-r--r--src/xbs-abs/Makefile15
l---------src/xbs-abslibre/GNUmakefile1
-rw-r--r--src/xbs-abslibre/Makefile5
l---------src/xbs/GNUmakefile1
-rw-r--r--src/xbs/Makefile1
20 files changed, 54 insertions, 34 deletions
diff --git a/src/GNUmakefile b/src/GNUmakefile
new file mode 120000
index 0000000..bb60b1e
--- /dev/null
+++ b/src/GNUmakefile
@@ -0,0 +1 @@
+../GNUmakefile \ No newline at end of file
diff --git a/src/Makefile b/src/Makefile
index 273a34b..2ba9534 100644
--- a/src/Makefile
+++ b/src/Makefile
@@ -1,7 +1,11 @@
include $(dir $(lastword $(MAKEFILE_LIST)))/../config.mk
include $(topsrcdir)/build-aux/Makefile.head.mk
+
pkgconfdir = $(sysconfdir)
-srcfiles-ignore/$(srcdir) = $(addsuffix /%,abslibre-tools chroot-tools devtools gitget lib librefetch toru xbs xbs-abs xbs-abslibre)
+# Because against all common sense, the subdirectories of this
+# directory aren't `nested.subdirs`, gitfiles includes the files in
+# them in `files.src.src`. So, filter-out everything with a slash.
+files.src.src := $(foreach f,$(files.src.src),$(if $(findstring /,$f),, $f ))
include $(topsrcdir)/build-aux/Makefile.tail.mk
diff --git a/src/abslibre-tools/GNUmakefile b/src/abslibre-tools/GNUmakefile
new file mode 120000
index 0000000..54fdd42
--- /dev/null
+++ b/src/abslibre-tools/GNUmakefile
@@ -0,0 +1 @@
+../../GNUmakefile \ No newline at end of file
diff --git a/src/chroot-tools/GNUmakefile b/src/chroot-tools/GNUmakefile
new file mode 120000
index 0000000..54fdd42
--- /dev/null
+++ b/src/chroot-tools/GNUmakefile
@@ -0,0 +1 @@
+../../GNUmakefile \ No newline at end of file
diff --git a/src/chroot-tools/Makefile b/src/chroot-tools/Makefile
index 96fb837..93655d7 100644
--- a/src/chroot-tools/Makefile
+++ b/src/chroot-tools/Makefile
@@ -1,27 +1,28 @@
include $(dir $(lastword $(MAKEFILE_LIST)))/../../config.mk
include $(topsrcdir)/build-aux/Makefile.head.mk
+
pkglibexecdir = $(libexecdir)/libretools/chroot
-libretools-bins = chcleanup librechroot libremakepkg
-libretools-libexecs += arch-nspawn chcleanup distcc-tool indent mkarchroot
-libretools-libs += makechrootpkg.sh
-devtools-files = makechrootpkg.sh.in mkarchroot.in arch-nspawn.in
-std.clean_files += chcleanup.lib
+libretools.src.devtools = makechrootpkg.sh.in mkarchroot.in arch-nspawn.in
+libretools.out.bins = chcleanup librechroot libremakepkg
+libretools.out.libexecs = arch-nspawn chcleanup distcc-tool indent mkarchroot
+libretools.out.libs = $(libretools.src.sh) makechrootpkg.sh
+files.out.int += chcleanup.lib
$(srcdir)/makechrootpkg.sh.in: $(srcdir)/%.sh.in: $(devtoolsdir)/%.in
cp $< $@
$(outdir)/chcleanup: $(srcdir)/chcleanup.in $(outdir)/chcleanup.lib
- m4 -I$(@D) -P $< | $(edit) | install -m755 /dev/stdin $@
+ m4 -I$(@D) -P $< | $(libretools.edit) | install -m755 /dev/stdin $@
$(outdir)/chcleanup.lib: $(call at.path,$(topoutdir)/src/lib/common.sh) $(outdir)/Makefile
bash -c '. $<; declare -f _l plain msg msg2 error' > $@
$(outdir)/distcc-tool.pot: LIBREXGETTEXT_FLAGS+=--simple=errusage
-$(DESTDIR)$(bindir)/chcleanup: $(var)bindir $(var)libexecdir
- mkdir -p $(@D)
+$(DESTDIR)$(bindir)/chcleanup: $(var.)bindir $(var.)libexecdir
+ $(MKDIR_P) $(@D)
ln -srfT $(DESTDIR)$(libexecdir)/libretools/chroot/chcleanup $@
-at.depdirs += ../lib
+at.subdirs += ../lib
include $(topsrcdir)/build-aux/Makefile.tail.mk
diff --git a/src/devtools/.gitignore b/src/devtools/.gitignore
index d669bbd..b9fef64 100644
--- a/src/devtools/.gitignore
+++ b/src/devtools/.gitignore
@@ -1,4 +1,5 @@
*
+!GNUmakefile
!Makefile
!.gitignore
!*.patch
diff --git a/src/devtools/GNUmakefile b/src/devtools/GNUmakefile
new file mode 120000
index 0000000..54fdd42
--- /dev/null
+++ b/src/devtools/GNUmakefile
@@ -0,0 +1 @@
+../../GNUmakefile \ No newline at end of file
diff --git a/src/devtools/Makefile b/src/devtools/Makefile
index 6d3f88c..4b7af11 100644
--- a/src/devtools/Makefile
+++ b/src/devtools/Makefile
@@ -1,12 +1,12 @@
include $(dir $(lastword $(MAKEFILE_LIST)))/../../config.mk
include $(topsrcdir)/build-aux/Makefile.head.mk
-libretools-bins += checkpkg find-libdeps finddeps lddd
-devtools-files = $(addsuffix .in,$(libretools-bins))
-std.sys_files += $(bindir)/find-libprovides
+libretools.out.bins = checkpkg find-libdeps finddeps lddd
+libretools.src.devtools = $(addsuffix .in,$(libretools.out.bins))
+files.sys.all += $(bindir)/find-libprovides
$(DESTDIR)$(bindir)/find-libprovides:
- install -d $(@D)
+ $(MKDIR_P) $(@D)
ln -sf find-libdeps $@
include $(topsrcdir)/build-aux/Makefile.tail.mk
diff --git a/src/gitget/GNUmakefile b/src/gitget/GNUmakefile
new file mode 120000
index 0000000..54fdd42
--- /dev/null
+++ b/src/gitget/GNUmakefile
@@ -0,0 +1 @@
+../../GNUmakefile \ No newline at end of file
diff --git a/src/lib/GNUmakefile b/src/lib/GNUmakefile
new file mode 120000
index 0000000..54fdd42
--- /dev/null
+++ b/src/lib/GNUmakefile
@@ -0,0 +1 @@
+../../GNUmakefile \ No newline at end of file
diff --git a/src/lib/Makefile b/src/lib/Makefile
index 9d52440..eb2ffde 100644
--- a/src/lib/Makefile
+++ b/src/lib/Makefile
@@ -1,12 +1,12 @@
include $(dir $(lastword $(MAKEFILE_LIST)))/../../config.mk
include $(topsrcdir)/build-aux/Makefile.head.mk
-libretools-libs += common.sh conf.sh
-devtools-files = common.sh.in
+libretools.src.devtools = common.sh.in
+libretools.out.libs += common.sh conf.sh
# Build ##############################################################
-$(outdir)/conf.sh: $(var)sysconfdir $(var)pkgconfdir
+$(outdir)/conf.sh: $(var.)sysconfdir $(var.)pkgconfdir
$(outdir)/common.sh: $(outdir)/%: $(srcdir)/%.in $(srcdir)/%.head $(srcdir)/%.tail $(outdir)/Makefile
@echo "OUT $@"
@@ -33,7 +33,7 @@ $(outdir)/blacklist.sh.pot: $(srcdir)/blacklist.sh $(srcdir)/librexgettext
sed -r -e 's/^# (.*)/msgid "\1"\nmsgstr ""\n/' \
-e 's|^[0-9]*$$|#. embedded usage text\n#: $<:&|' && \
$(<D)/librexgettext --simple=_l:2 $< && \
- :; } | $(pofmt) > $@
+ :; } | $(libretools.pofmt) > $@
$(outdir)/common.sh.pot : LIBREXGETTEXT_FLAGS += --simple=_l:2
$(outdir)/conf.sh.pot : LIBREXGETTEXT_FLAGS += --simple=_l:2
$(outdir)/librelib.pot : LIBREXGETTEXT_FLAGS += --simple=_l:2
diff --git a/src/librefetch/GNUmakefile b/src/librefetch/GNUmakefile
new file mode 120000
index 0000000..54fdd42
--- /dev/null
+++ b/src/librefetch/GNUmakefile
@@ -0,0 +1 @@
+../../GNUmakefile \ No newline at end of file
diff --git a/src/librefetch/Makefile b/src/librefetch/Makefile
index b40c15b..f11f0ed 100644
--- a/src/librefetch/Makefile
+++ b/src/librefetch/Makefile
@@ -1,13 +1,13 @@
include $(dir $(lastword $(MAKEFILE_LIST)))/../../config.mk
include $(topsrcdir)/build-aux/Makefile.head.mk
-libretools-bins = librefetch librefetch-install
-libretools-confs += librefetch-makepkg.conf
-libretools-libexecs += $(filter librefetchdir/%,$(detect-exec))
-libretools-libs += $(filter-out $(libretools-libexecs),$(filter librefetchdir/%,$(detect-all)))
-pots = $(libretools-bins)
+libretools.out.bins = librefetch librefetch-install
+libretools.out.confs = $(libretools.src.conf) librefetch-makepkg.conf
+libretools.out.libexecs = $(filter librefetchdir/%,$(libretools.src.exec))
+libretools.out.libs = $(filter-out $(libretools.out.libexecs),$(filter librefetchdir/%,$(libretools.src.git)))
+libretools.pots = $(libretools.out.bins)
-$(outdir)/librefetch-install: $(var)pkgconfdir
-$(outdir)/librefetch-makepkg.conf: $(var)bindir
+$(outdir)/librefetch-install: $(var.)pkgconfdir
+$(outdir)/librefetch-makepkg.conf: $(var.)bindir
include $(topsrcdir)/build-aux/Makefile.tail.mk
diff --git a/src/toru/GNUmakefile b/src/toru/GNUmakefile
new file mode 120000
index 0000000..54fdd42
--- /dev/null
+++ b/src/toru/GNUmakefile
@@ -0,0 +1 @@
+../../GNUmakefile \ No newline at end of file
diff --git a/src/xbs-abs/GNUmakefile b/src/xbs-abs/GNUmakefile
new file mode 120000
index 0000000..54fdd42
--- /dev/null
+++ b/src/xbs-abs/GNUmakefile
@@ -0,0 +1 @@
+../../GNUmakefile \ No newline at end of file
diff --git a/src/xbs-abs/Makefile b/src/xbs-abs/Makefile
index 65be914..2d3d297 100644
--- a/src/xbs-abs/Makefile
+++ b/src/xbs-abs/Makefile
@@ -1,15 +1,16 @@
include $(dir $(lastword $(MAKEFILE_LIST)))/../../config.mk
include $(topsrcdir)/build-aux/Makefile.head.mk
+
pkgconfdir = $(sysconfdir)/xbs
pkglibexecdir = $(libexecdir)/xbs
-_helpers = archrelease commitpkg
-libretools-bins =
-libretools-libexecs = helper-abs
-pots += $(_helpers)
-devtools-files += $(addsuffix .in,$(_helpers))
-std.out_files += $(_helpers)
-std.sys_files += $(addprefix $(pkglibexecdir)/helper-abs.d/,$(_helpers))
+_helpers = archrelease commitpkg
+libretools.out.bins =
+libretools.out.libexecs = helper-abs
+libretools.pots += $(_helpers)
+libretools.src.devtools += $(addsuffix .in,$(_helpers))
+files.out.all += $(_helpers)
+files.sys.all += $(addprefix $(pkglibexecdir)/helper-abs.d/,$(_helpers))
$(outdir)/commitpkg: $(srcdir)/commitpkg.in
@echo "OUT $@"
diff --git a/src/xbs-abslibre/GNUmakefile b/src/xbs-abslibre/GNUmakefile
new file mode 120000
index 0000000..54fdd42
--- /dev/null
+++ b/src/xbs-abslibre/GNUmakefile
@@ -0,0 +1 @@
+../../GNUmakefile \ No newline at end of file
diff --git a/src/xbs-abslibre/Makefile b/src/xbs-abslibre/Makefile
index 71da5e7..a86b958 100644
--- a/src/xbs-abslibre/Makefile
+++ b/src/xbs-abslibre/Makefile
@@ -1,8 +1,9 @@
include $(dir $(lastword $(MAKEFILE_LIST)))/../../config.mk
include $(topsrcdir)/build-aux/Makefile.head.mk
+
pkglibexecdir = $(libexecdir)/xbs
-libretools-bins =
-libretools-libexecs = helper-abslibre
+libretools.out.bins =
+libretools.out.libexecs = helper-abslibre
include $(topsrcdir)/build-aux/Makefile.tail.mk
diff --git a/src/xbs/GNUmakefile b/src/xbs/GNUmakefile
new file mode 120000
index 0000000..54fdd42
--- /dev/null
+++ b/src/xbs/GNUmakefile
@@ -0,0 +1 @@
+../../GNUmakefile \ No newline at end of file
diff --git a/src/xbs/Makefile b/src/xbs/Makefile
index 24067e9..bc9f4c8 100644
--- a/src/xbs/Makefile
+++ b/src/xbs/Makefile
@@ -1,5 +1,6 @@
include $(dir $(lastword $(MAKEFILE_LIST)))/../../config.mk
include $(topsrcdir)/build-aux/Makefile.head.mk
+
pkgconfdir = $(sysconfdir)/xbs
include $(topsrcdir)/build-aux/Makefile.tail.mk