summaryrefslogtreecommitdiff
path: root/test/librefetch.d
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@lukeshu.com>2017-05-01 17:14:16 -0400
committerLuke Shumaker <lukeshu@lukeshu.com>2017-05-01 17:24:16 -0400
commit8ab3d92ccf278389721b1ae8ff42dffef0e066ab (patch)
treebd7b07c405e6f43ef8a886f516b4616653d6644c /test/librefetch.d
parentcd795c1446b705b2e14cf70655e859571d4f8755 (diff)
bugfix [1/2]: librefetch: Add check for SRCBUILD-to-SRCBUILD operation
Diffstat (limited to 'test/librefetch.d')
-rw-r--r--test/librefetch.d/PKGBUILD-mksource (renamed from test/librefetch.d/PKGBUILD)0
-rw-r--r--test/librefetch.d/PKGBUILD-srcbuild10
-rw-r--r--test/librefetch.d/SRCBUILD-srcbuild21
3 files changed, 31 insertions, 0 deletions
diff --git a/test/librefetch.d/PKGBUILD b/test/librefetch.d/PKGBUILD-mksource
index 6547e25..6547e25 100644
--- a/test/librefetch.d/PKGBUILD
+++ b/test/librefetch.d/PKGBUILD-mksource
diff --git a/test/librefetch.d/PKGBUILD-srcbuild b/test/librefetch.d/PKGBUILD-srcbuild
new file mode 100644
index 0000000..40c5c79
--- /dev/null
+++ b/test/librefetch.d/PKGBUILD-srcbuild
@@ -0,0 +1,10 @@
+pkgname=testpkg
+pkgver=1.0
+pkgrel=1
+pkgdesc=foo
+arch=(any)
+source=("libre://$pkgname-$pkgver.tar.gz"{,.sig})
+
+package() {
+ :;
+}
diff --git a/test/librefetch.d/SRCBUILD-srcbuild b/test/librefetch.d/SRCBUILD-srcbuild
new file mode 100644
index 0000000..6f172c5
--- /dev/null
+++ b/test/librefetch.d/SRCBUILD-srcbuild
@@ -0,0 +1,21 @@
+pkgname=testpkg
+pkgver=1.0
+pkgrel=1
+pkgdesc=foo
+arch=(any)
+source=()
+
+PKGDEST=$SRCDEST
+PKGEXT=$SRCEXT
+
+build() {
+ mkdir "$srcdir/bar"
+ local file
+ for file in '~foo' '~a' a A; do
+ touch "$srcdir/bar/$file"
+ done
+}
+
+package() {
+ cp -a -t "$pkgdir" "$srcdir"/*
+}