summaryrefslogtreecommitdiff
path: root/test/libremakepkg.d/PKGBUILD-hello
diff options
context:
space:
mode:
authorLuke Shumaker <LukeShu@sbcglobal.net>2013-06-01 16:46:15 -0600
committerLuke Shumaker <LukeShu@sbcglobal.net>2013-06-05 20:01:05 -0600
commitfbed0b50c73f1ed06bc47d490ce8ab78428c8e78 (patch)
treee89bead95bed60de8308837ce534445e5b38d385 /test/libremakepkg.d/PKGBUILD-hello
parent0b2139ee355ca73b9ddfeebf8c3881ce4f1c22c1 (diff)
add a few tests for libremakepkg
Diffstat (limited to 'test/libremakepkg.d/PKGBUILD-hello')
-rw-r--r--test/libremakepkg.d/PKGBUILD-hello19
1 files changed, 19 insertions, 0 deletions
diff --git a/test/libremakepkg.d/PKGBUILD-hello b/test/libremakepkg.d/PKGBUILD-hello
new file mode 100644
index 0000000..706cb24
--- /dev/null
+++ b/test/libremakepkg.d/PKGBUILD-hello
@@ -0,0 +1,19 @@
+pkgname='libretools-hello'
+pkgver=1.0
+license=('GPL')
+url='https://parabolagnulinux.org'
+
+pkgrel=1
+arch=(any)
+depends=(sh)
+
+build() {
+ cd "$srcdir"
+ echo '#!/bin/sh' > hello.sh
+ echo 'echo Hello, world!' >> hello.sh
+}
+
+package() {
+ cd "$srcdir"
+ install -Dm755 hello.sh "$pkgdir"/usr/bin/libretools-hello
+}