summaryrefslogtreecommitdiff
path: root/test/libremakepkg.d
diff options
context:
space:
mode:
authorLuke Shumaker <LukeShu@sbcglobal.net>2014-02-02 20:54:07 -0500
committerLuke Shumaker <LukeShu@sbcglobal.net>2014-02-02 20:54:07 -0500
commitef7a330eae68da2f47c617502b28a2f8c9eeb792 (patch)
treef51373a47a19f8003069e16ead842b395a4b2b04 /test/libremakepkg.d
parent804e5e1093c3aa8258bf9f8c97ff661cdf8407f1 (diff)
libremakepkg-test: test the -N flag
Diffstat (limited to 'test/libremakepkg.d')
-rw-r--r--test/libremakepkg.d/PKGBUILD-netbuild16
-rw-r--r--test/libremakepkg.d/PKGBUILD-netpackage12
2 files changed, 28 insertions, 0 deletions
diff --git a/test/libremakepkg.d/PKGBUILD-netbuild b/test/libremakepkg.d/PKGBUILD-netbuild
new file mode 100644
index 0000000..c1335a6
--- /dev/null
+++ b/test/libremakepkg.d/PKGBUILD-netbuild
@@ -0,0 +1,16 @@
+pkgname='libretools-netbuild'
+pkgver=1.0
+license=('GPL')
+url='https://parabolagnulinux.org'
+
+pkgrel=1
+arch=(any)
+
+build() {
+ curl https://repo.parabolagnulinux.org/ > index.html
+}
+
+package() {
+ cd "$srcdir"
+ install -Dm644 index.html "$pkgdir"/usr/share/$pkgname/index.html
+}
diff --git a/test/libremakepkg.d/PKGBUILD-netpackage b/test/libremakepkg.d/PKGBUILD-netpackage
new file mode 100644
index 0000000..cbefe8f
--- /dev/null
+++ b/test/libremakepkg.d/PKGBUILD-netpackage
@@ -0,0 +1,12 @@
+pkgname='libretools-netpackage'
+pkgver=1.0
+license=('GPL')
+url='https://parabolagnulinux.org'
+
+pkgrel=1
+arch=(any)
+
+package() {
+ install -d "$pkgdir"/usr/share/$pkgname
+ curl https://repo.parabolagnulinux.org/ > "$pkgdir"/usr/share/$pkgname/index.html
+}