summaryrefslogtreecommitdiff
path: root/test/librestage-test.sh
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@sbcglobal.net>2015-01-01 20:57:13 -0500
committerLuke Shumaker <lukeshu@sbcglobal.net>2015-01-01 20:57:13 -0500
commit503517c61c64bb18dc64574b5b02fb973a110891 (patch)
tree1b048174d1bd580a907e97f59ee77294c24ccaa5 /test/librestage-test.sh
parent2c981bb6e7f5ddb1b71a2a4e314ba7cd523d857c (diff)
makepkg no longer supports split packages with different pkgver
Diffstat (limited to 'test/librestage-test.sh')
-rw-r--r--test/librestage-test.sh14
1 files changed, 0 insertions, 14 deletions
diff --git a/test/librestage-test.sh b/test/librestage-test.sh
index edcfc36..affad6a 100644
--- a/test/librestage-test.sh
+++ b/test/librestage-test.sh
@@ -48,20 +48,6 @@ it_fails_with_invalid_args() {
not empty "$tmpdir/stderr"
}
-# This was an actual bug I hit with md/emacs-mdmua a long time ago; solution was
-# to use $(get_full_version)
-it_stages_split_packages_with_different_versions() {
- cp librestage.d/PKGBUILD-split "$tmpdir/PKGBUILD"
- cd "$tmpdir"
-
- makepkg
- librestage '~lukeshu'
-
- # peak at the PKGBUILD to get this info
- [[ -f $tmpdir/workdir/staging/~lukeshu/md-0.81-4-any.pkg.tar.gz ]]
- [[ -f $tmpdir/workdir/staging/~lukeshu/emacs-mdmua-0.72-4-any.pkg.tar.gz ]]
-}
-
it_guesses_the_repo() {
mkdir -p -- "$tmpdir/reponame/libretools-hello"
cp librestage.d/PKGBUILD-hello "$tmpdir/reponame/libretools-hello/PKGBUILD"