summaryrefslogtreecommitdiff
path: root/test/librexgettext.d/it_handles_librefetch_flags.sh
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@lukeshu.com>2017-07-09 18:15:49 -0400
committerLuke Shumaker <lukeshu@lukeshu.com>2017-07-09 18:30:59 -0400
commit6b772f881dd8bb1a2a40181e6c76187c9c847c30 (patch)
treed9f2c1204f5a884233c6da32fd74fe8276fdcc00 /test/librexgettext.d/it_handles_librefetch_flags.sh
parent5dfaaed8f7002ee1385c93fa14647ff128138f12 (diff)
test: librexgettext: Add tests
Diffstat (limited to 'test/librexgettext.d/it_handles_librefetch_flags.sh')
-rw-r--r--test/librexgettext.d/it_handles_librefetch_flags.sh15
1 files changed, 15 insertions, 0 deletions
diff --git a/test/librexgettext.d/it_handles_librefetch_flags.sh b/test/librexgettext.d/it_handles_librefetch_flags.sh
new file mode 100644
index 0000000..579ca96
--- /dev/null
+++ b/test/librexgettext.d/it_handles_librefetch_flags.sh
@@ -0,0 +1,15 @@
+#!/usr/bin/env bash
+. libremessages
+
+flag 'Settings:' \
+ "-C" "Force create mode (don't download)" \
+ "-D" "Force download mode (don't create)" \
+ "-p <$(_ FILE)>" "Use an alternate build script (instead of
+ 'PKGBUILD'). If an SRCBUILD exists in the same
+ directory, it is used instead" \
+ 'Alternate modes:' \
+ "-g, --geninteg" "Generate integrity checks for source files" \
+ "-S, --srcbuild" "Print the effective build script (SRCBUILD)" \
+ "-M, --makepkg" "Generate and print the location of the
+ effective makepkg script" \
+ "-h, --help" "Show this message"