summaryrefslogtreecommitdiff
path: root/test
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@lukeshu.com>2018-05-29 16:27:57 -0400
committerLuke Shumaker <lukeshu@lukeshu.com>2018-05-30 11:39:51 -0400
commit2ea06887de6ce12c7ee6f16acad2ecde68510d57 (patch)
tree7b7c2161268010c4ab20c991a0d67bfe51ee8928 /test
parent6aae21e666601687011f4de5749189d5fde950e0 (diff)
test/librefetch: Verify that it doesn't complain about backup=() entries [ci-skip]
https://labs.parabola.nu/issues/1186
Diffstat (limited to 'test')
-rw-r--r--test/librefetch-test.sh6
-rw-r--r--test/librefetch.d/PKGBUILD-mksource1
2 files changed, 6 insertions, 1 deletions
diff --git a/test/librefetch-test.sh b/test/librefetch-test.sh
index 8018784..fc92079 100644
--- a/test/librefetch-test.sh
+++ b/test/librefetch-test.sh
@@ -76,11 +76,15 @@ it_runs_with_mksource() {
touch src-libre/foo/file
# Run librefetch
- makepkg -g
+ makepkg -g >& log.txt
# Verify that no temporary files were left around
not test -e librefetch.*
+ # Verify that there were no warnings about missing backup=()
+ # files
+ not grep -F etc/testpkg.conf log.txt
+
# Verify:
# - The srcball was created...
# - ... and is in the correct directory
diff --git a/test/librefetch.d/PKGBUILD-mksource b/test/librefetch.d/PKGBUILD-mksource
index 6547e25..74489de 100644
--- a/test/librefetch.d/PKGBUILD-mksource
+++ b/test/librefetch.d/PKGBUILD-mksource
@@ -4,6 +4,7 @@ pkgrel=1
pkgdesc=foo
arch=(any)
source=("libre://$pkgname-$pkgver.tar.gz"{,.sig})
+backup=(etc/testpkg.conf)
mksource() {
mkdir "$srcdir/bar"