summaryrefslogtreecommitdiff
path: root/test
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@lukeshu.com>2017-07-09 18:17:29 -0400
committerLuke Shumaker <lukeshu@lukeshu.com>2017-07-09 18:25:37 -0400
commit5dfaaed8f7002ee1385c93fa14647ff128138f12 (patch)
treedf8d1bbc70dc585e9d4fce278c5248b688d4862a /test
parent5b686bdd35959ff8ffc8636035e89c1457c6d9c9 (diff)
testenv: make resilient to changes in config.mk
Diffstat (limited to 'test')
-rwxr-xr-xtest/testenv3
1 files changed, 2 insertions, 1 deletions
diff --git a/test/testenv b/test/testenv
index 3bb827f..a744308 100755
--- a/test/testenv
+++ b/test/testenv
@@ -1,4 +1,5 @@
#!/usr/bin/env bash
+set -e
# Parse the arguments
NETWORK=true
@@ -31,7 +32,7 @@ old_pwd="$(pwd)"
if [[ -f $0 ]]; then
cd "${0%/*}"
fi
-if ! make -C .. install DESTDIR="$destdir" &>"$TMPDIR/make-output"; then
+if ! make -C .. install prefix=/usr sysconfdir=/etc DESTDIR="$destdir" &>"$TMPDIR/make-output"; then
echo 'error creating local install, cannot run tests' >&2
cat "$TMPDIR/make-output"
exit 1