summaryrefslogtreecommitdiff
path: root/test
diff options
context:
space:
mode:
authorLuke Shumaker <LukeShu@sbcglobal.net>2014-06-16 18:58:28 -0400
committerLuke Shumaker <LukeShu@sbcglobal.net>2014-06-16 18:58:28 -0400
commit813bfa255a1e46f05e08dcb587b8f417b995b2d4 (patch)
treed2feedc9b750edf52788c767cc666daebb8d3884 /test
parent8831cc585ae8e9071f8c022bdfaf75e42029d7e4 (diff)
parent5051daebf722a9020b015feabc4c39e6bdb187f1 (diff)
Merge branch 'master' of ssh://projects.parabolagnulinux.org:1863/~git/packages/libretools
Conflicts: src/librefetch/librefetch.8.ronn
Diffstat (limited to 'test')
-rw-r--r--test/librechroot-test.sh2
-rw-r--r--test/librefetch-test.sh3
-rw-r--r--test/librefetch.d/PKGBUILD5
-rw-r--r--test/librefetch.d/list.txt5
4 files changed, 11 insertions, 4 deletions
diff --git a/test/librechroot-test.sh b/test/librechroot-test.sh
index c22ac58..43f3143 100644
--- a/test/librechroot-test.sh
+++ b/test/librechroot-test.sh
@@ -40,7 +40,7 @@ it_respects_exit_status_if_out_isnt_a_tty() (
set -o pipefail
libremessages msg 'Creating a chroot, may take a few minutes' &>/dev/tty
r=0
- { testsudo librechroot -l "$roundup_test_name" run exit 3 | cat; } || r=$?
+ { testsudo librechroot -l "$roundup_test_name" run bash -c 'exit 3' | cat; } || r=$?
[[ $r == 3 ]]
)
diff --git a/test/librefetch-test.sh b/test/librefetch-test.sh
index 43b7a69..9db836b 100644
--- a/test/librefetch-test.sh
+++ b/test/librefetch-test.sh
@@ -9,7 +9,7 @@ before() {
mkdir -p "$HOME"
printf '%s\n' \
- "DLAGENTS+=({https,libre}'::$(which librefetch) -p \"\$BUILDFILE\" -- %u %o')" \
+ "DLAGENTS=({https,libre}'::$(which librefetch) -p \"\$BUILDFILE\" -- %u %o')" \
'BUILDDIR=""' \
> "$HOME/.makepkg.conf"
@@ -31,6 +31,7 @@ it_displays_help() {
empty $tmpdir/stderr
}
+# This test also does a rough test of file order in the PKGBUILD
it_cleans_src_libre_first() {
cp librefetch.d/* "$tmpdir/"
cd "$tmpdir"
diff --git a/test/librefetch.d/PKGBUILD b/test/librefetch.d/PKGBUILD
index 723d82e..db80db3 100644
--- a/test/librefetch.d/PKGBUILD
+++ b/test/librefetch.d/PKGBUILD
@@ -7,7 +7,10 @@ source=("libre://$pkgname-$pkgver.tar.gz")
mksource() {
mkdir "$srcdir/bar"
- touch "$srcdir/bar/file"
+ local file
+ for file in '~foo' '~a' a A; do
+ touch "$srcdir/bar/$file"
+ done
}
package() {
diff --git a/test/librefetch.d/list.txt b/test/librefetch.d/list.txt
index b04d5d1..9bd32f4 100644
--- a/test/librefetch.d/list.txt
+++ b/test/librefetch.d/list.txt
@@ -1,2 +1,5 @@
bar/
-bar/file
+bar/A
+bar/a
+bar/~a
+bar/~foo