summaryrefslogtreecommitdiff
path: root/test
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@lukeshu.com>2017-05-12 15:55:56 -0400
committerLuke Shumaker <lukeshu@lukeshu.com>2017-05-12 15:56:19 -0400
commitfb3294eacfae13cb36a2998e63ead2d2dd3b02e4 (patch)
tree192c54784549b4965f3642fc0cccb66531a9da3a /test
parentc9078755fcb8bf1b661a7caac822dee03f1a0dbc (diff)
test: librefetch: add (failing) check for unnescessary recursion
Diffstat (limited to 'test')
-rw-r--r--test/librefetch-test.sh12
1 files changed, 12 insertions, 0 deletions
diff --git a/test/librefetch-test.sh b/test/librefetch-test.sh
index f9041db..8018784 100644
--- a/test/librefetch-test.sh
+++ b/test/librefetch-test.sh
@@ -135,3 +135,15 @@ it_recurses() {
diff -u list.txt list-pkg.txt
gpg --quiet --verify "$tmpdir/srcdest/$srcball"{.sig,} 2>/dev/null
}
+
+it_doesnt_recurse_extra() {
+ local srcball=testpkg-1.0.tar.gz
+ cp librefetch.d/* "$tmpdir/"
+ cd "$tmpdir"
+ mv PKGBUILD{-recurse,}
+
+ :> "$tmpdir/srcdest/$srcball"
+ makepkg -g
+ empty "$tmpdir/srcdest/$srcball"
+ gpg --quiet --verify "$tmpdir/srcdest/$srcball"{.sig,} 2>/dev/null
+}