summaryrefslogtreecommitdiff
path: root/test
diff options
context:
space:
mode:
authorLuke Shumaker <LukeShu@sbcglobal.net>2013-09-10 00:42:25 -0400
committerLuke Shumaker <LukeShu@sbcglobal.net>2013-09-11 15:23:29 -0400
commit2c38dbeb2eea18be19ff13391a2069e37096ac71 (patch)
tree0a09be868cc38d8cf7ccbb61cdf4b74f021ef0d5 /test
parented70c3d52624dbe2be6a4d8e7f8858f94258c8bb (diff)
test: tidy up
- libremakepkg: set BLACKLIST, as it will be used when checking the PKGBUILD - test-common.sh: make sure that $HOME isn't the default, so we don't trash the user's home directory if accidentally run outside of testenv - testenv: don't worry about adding dest/usr/sbin to the path
Diffstat (limited to 'test')
-rw-r--r--test/libremakepkg-test.sh3
-rw-r--r--test/test-common.sh5
-rwxr-xr-xtest/testenv2
3 files changed, 9 insertions, 1 deletions
diff --git a/test/libremakepkg-test.sh b/test/libremakepkg-test.sh
index 011674a..90cca0b 100644
--- a/test/libremakepkg-test.sh
+++ b/test/libremakepkg-test.sh
@@ -8,6 +8,9 @@ before() {
_before libremakepkg
mkdir -p "$XDG_CONFIG_HOME"/libretools
+
+ echo "BLACKLIST=https://repo.parabolagnulinux.org/docs/blacklist.txt" >"$XDG_CONFIG_HOME"/libretools/libretools.conf
+
echo "CHROOTDIR='$tmpdir/chrootdir'" > "$XDG_CONFIG_HOME"/libretools/chroot.conf
echo "CHROOT='default'" >> "$XDG_CONFIG_HOME"/libretools/chroot.conf
echo "CHROOTEXTRAPKG=()" >> "$XDG_CONFIG_HOME"/libretools/chroot.conf
diff --git a/test/test-common.sh b/test/test-common.sh
index e837498..85c05c5 100644
--- a/test/test-common.sh
+++ b/test/test-common.sh
@@ -1,5 +1,10 @@
#!/bin/bash
+if [[ $HOME == "$(eval echo ~$USER)" ]]; then
+ libremessages error "\$HOME is the default for %s; use testenv: %s" "$USER" "$HOME"
+ exit 1
+fi
+
_before() {
tmpdir="$(mktemp -d --tmpdir "test-$1.XXXXXXXXXXXX")"
stat=0
diff --git a/test/testenv b/test/testenv
index e6f49fb..e6c882f 100755
--- a/test/testenv
+++ b/test/testenv
@@ -33,7 +33,7 @@ make -C .. install DESTDIR=$destdir &>/dev/null || {
cd "$old_pwd"
# Set up the environment
-export PATH="$destdir/usr/bin:$destdir/usr/sbin:$PATH"
+export PATH="$destdir/usr/bin:$PATH"
export LIBRETOOLS_LIBDIR="$destdir/usr/lib/libretools"
export HOME=$TMPDIR/home
export XDG_CACHE_HOME="$HOME/.cache"