summaryrefslogtreecommitdiff
path: root/toru-utils
diff options
context:
space:
mode:
authorJoshua I. Haase H. (xihh) <hahj87@gmail.com>2012-05-08 01:58:02 -0500
committerJoshua I. Haase H. (xihh) <hahj87@gmail.com>2012-05-08 01:58:02 -0500
commit3dcf773de928a0a587f0409d2bd1d7ecad80b549 (patch)
treebf66d492479bb9f454b9700b58fc53c114ae4e7d /toru-utils
parente13b2d4ae996c164b8082bfa18a7351ddb4467d7 (diff)
parent112b6427bf299b9db8fc34e5b771fecf1958db07 (diff)
Merge branch 'master' of gitpar:libretools
Conflicts: toru-utils
Diffstat (limited to 'toru-utils')
-rwxr-xr-xtoru-utils15
1 files changed, 6 insertions, 9 deletions
diff --git a/toru-utils b/toru-utils
index 7e6d62d..0818aa6 100755
--- a/toru-utils
+++ b/toru-utils
@@ -59,17 +59,14 @@ get_pkgbuilds() {
$QUIET || warning "Forcing upgrade"
# Get all PKGBUILDs
- pkgbuilds=($(find $@ -mindepth 2 -maxdepth 3 -type f -name 'PKGBUILD'))
-
+ extra=""
else
-
# Only find newer than lastsyncfile and read everything else from cache
- pkgbuilds=($(find $@ -mindepth 2 -maxdepth 3 -type f -name 'PKGBUILD' -newer ${LASTSYNCFILE}))
-
+ extra=" -newer ${LASTSYNCFILE}"
fi
# Return all PKGBUILDs found
- echo ${pkgbuilds[@]}
+ find $@ -mindepth 2 -maxdepth 3 -type f -name 'PKGBUILD' ${extra}
}
# End inmediately but print a useful message
@@ -81,6 +78,6 @@ trap_exit() {
# Trap signals from makepkg
set -E
-trap 'trap_exit "($(basename $0):${level}) TERM signal caught. Exiting..."' TERM HUP QUIT
-trap 'trap_exit "($(basename $0):${level}) Aborted by user! Exiting..."' INT
-trap 'trap_exit "($(basename $0):${level}) An unknown error has occurred. Exiting..."' ERR
+trap 'trap_exit "TERM signal caught. Exiting..."' TERM HUP QUIT
+trap 'trap_exit "Aborted by user! Exiting..."' INT
+trap 'trap_exit "An unknown error has occurred. Exiting..."' ERR