summaryrefslogtreecommitdiff
path: root/toru
diff options
context:
space:
mode:
authorJoshua Ismael Haase Hernández <hahj87@gmail.com>2011-12-27 20:07:08 -0600
committerJoshua Ismael Haase Hernández <hahj87@gmail.com>2011-12-27 20:07:08 -0600
commitfa0b7b6f8e45982f1e2317c386ef0cf49ee840c7 (patch)
tree2573cfa613140509351277a59d3f30eb98107d82 /toru
parentc4eecdae6106541bfd94c17302c7c55b20754adb (diff)
libremakepkg: fixed conditionals
toru: -p exit with 1 status if not found
Diffstat (limited to 'toru')
-rwxr-xr-xtoru9
1 files changed, 7 insertions, 2 deletions
diff --git a/toru b/toru
index a054ddf..5867bfe 100755
--- a/toru
+++ b/toru
@@ -280,11 +280,14 @@ where_is() {
[ -n "${_path}" ] && break
done
+ [ -z "$_path" ] && return 1
+
echo ${_path}
}
# TODO: clean usage instructions
function usage {
+ echo ""
echo "$0 [options] repo1 ... repon"
echo ""
echo "Make a db containing PKGBUILD metadata."
@@ -295,6 +298,7 @@ function usage {
echo "-q : quiet"
echo "-f : rebuild the db even if it is updated"
echo "-p <pkgname>: return the path for pkgname"
+ echo ""
exit 1
}
@@ -306,13 +310,14 @@ force=false
while getopts 'haqfpum' arg; do
case $arg in
h) usage; exit 0 ;;
-# a) update_all_repos ;;
+# TODO: Update all repos on $REPOS array
+# a) update_all_repos ;;
q) quiet=true ;;
f) force=true ;;
u) commands+=(update);;
p) shift $(( OPTIND - 1 ))
where_is "$1"
- exit 0;;
+ exit $?;;
m) commands+=(missing);;
esac