summaryrefslogtreecommitdiff
path: root/toru
diff options
context:
space:
mode:
authorMichał Masłowski <mtjm@mtjm.eu>2012-02-18 13:53:07 +0100
committerMichał Masłowski <mtjm@mtjm.eu>2012-02-18 13:53:07 +0100
commit77647dc95bec7f72a5ecee7d303aa2802f39adb4 (patch)
tree0440732549eb457148da5f6c3479f3e87c0ee498 /toru
parent79444786617ee442c2e16bc37651d9982cfcf474 (diff)
Fix some toru "unknown errors".
Diffstat (limited to 'toru')
-rwxr-xr-xtoru4
1 files changed, 2 insertions, 2 deletions
diff --git a/toru b/toru
index 41acb18..de0e92f 100755
--- a/toru
+++ b/toru
@@ -137,7 +137,7 @@ update() {
fi
- package_paths=($(read_cache ${_repo}.paths))
+ package_paths=($(read_cache ${_repo}.paths || true))
# Inform how many PKGBUILDS were found and quit immediately if none
$quiet || msg "Found $((${#pkgbuilds[*]}-1)) PKGBUILDs to update"
@@ -165,7 +165,7 @@ update() {
for _pkg in ${pkgname[@]}; do
# Keep removing unneeded stuff
- unset package_${_pkg} >/dev/null 2>&1
+ unset package_${_pkg} >/dev/null 2>&1 || true
# Fill the list of packages to find
packages_in_abs+=($_pkg-$(get_full_version ${epoch:-0} $pkgver $pkgrel))
package_paths+=($_pkg:$_pkgpath)