summaryrefslogtreecommitdiff
path: root/treepkg
diff options
context:
space:
mode:
authorNicolás Reynolds <fauno@kiwwwi.com.ar>2012-08-15 15:28:35 -0300
committerNicolás Reynolds <fauno@kiwwwi.com.ar>2012-08-15 15:28:35 -0300
commitb3b52d5c4a3cbcdeb505b099230107b830290e8e (patch)
treee9e469c43bfecd1d96d27506b3724ce973647019 /treepkg
parentfe138085ad889447942f03b969f1a3abb862cb8a (diff)
TODO was implemented already
Diffstat (limited to 'treepkg')
-rwxr-xr-xtreepkg5
1 files changed, 1 insertions, 4 deletions
diff --git a/treepkg b/treepkg
index fcb9d29..00ec0e0 100755
--- a/treepkg
+++ b/treepkg
@@ -157,13 +157,10 @@ if ! ${BUILDNOW}; then
# NOTE: getting depends from package() is a PITA
for _dep in ${deps[@]}; do
-# Ignore if already in build order
-# TODO move deps deeper in the tree if
+# Move deps deeper in the tree if
# pkgbase - dep1
# \ dep2 - dep1
# dep1 should be depth + 1
-# probably sed -i buildorder and increase dep's dep depth :D
-# remember to change dir name from xxx_pkgbase to xxx+1_pkgbase
egrep -q ";${_dep};" "${BUILDORDER}" && bury "${_dep}" ${NEXTDEPTH}
# Ask toru where's a PKGBUILD