summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--test/librechroot-test.sh16
-rw-r--r--test/librechroot.d/PKGBUILD-arches (renamed from test/librechroot.d/PKGBUILD)0
-rw-r--r--test/librechroot.d/PKGBUILD-libretools20
3 files changed, 35 insertions, 1 deletions
diff --git a/test/librechroot-test.sh b/test/librechroot-test.sh
index 00ca2ed..93e7833 100644
--- a/test/librechroot-test.sh
+++ b/test/librechroot-test.sh
@@ -71,7 +71,7 @@ it_obeys_depends_in_PKGBUILD() {
not testsudo librechroot -l "$roundup_test_name" run lsof
# Make sure it leaves it with the PKGBUILD
testsudo librechroot -l "$roundup_test_name" install-name lsof
- testsudo librechroot -l "$roundup_test_name" run sh -c 'printf "%s\n" "$1" > /startdir/PKGBUILD' -- "$(cat librechroot.d/PKGBUILD)"
+ testsudo librechroot -l "$roundup_test_name" run sh -c 'printf "%s\n" "$1" > /startdir/PKGBUILD' -- "$(cat librechroot.d/PKGBUILD-arches)"
# uid=99 is 'nobody', but we say '99' because sometimes 'nobody' is uid=65534.
# https://bugs.archlinux.org/task/56828
testsudo librechroot -l "$roundup_test_name" run chown -R 99:99 /startdir
@@ -79,6 +79,20 @@ it_obeys_depends_in_PKGBUILD() {
testsudo librechroot -l "$roundup_test_name" run lsof
}
+it_can_install_libretools_with_chcleanup() {
+ require network sudo || return 0
+ libremessages msg 'Creating a chroot, may take a few minutes' &>/dev/tty
+
+ not testsudo librechroot -l "$roundup_test_name" run test -f /usr/bin/chcleanup
+ testsudo librechroot -l "$roundup_test_name" run mkdir /startdir
+ testsudo librechroot -l "$roundup_test_name" run sh -c 'printf "%s\n" "$1" > /startdir/PKGBUILD' -- "$(cat librechroot.d/PKGBUILD-libretools)"
+ # uid=99 is 'nobody', but we say '99' because sometimes 'nobody' is uid=65534.
+ # https://bugs.archlinux.org/task/56828
+ testsudo librechroot -l "$roundup_test_name" run chown -R 99:99 /startdir
+ testsudo librechroot -l "$roundup_test_name" clean-pkgs
+ testsudo librechroot -l "$roundup_test_name" run test -f /usr/bin/chcleanup
+}
+
it_displays_help_as_normal_user() {
rm -rf "$XDG_CONFIG_HOME"
LC_ALL=C librechroot help >$tmpdir/stdout 2>$tmpdir/stderr
diff --git a/test/librechroot.d/PKGBUILD b/test/librechroot.d/PKGBUILD-arches
index 6116ad9..6116ad9 100644
--- a/test/librechroot.d/PKGBUILD
+++ b/test/librechroot.d/PKGBUILD-arches
diff --git a/test/librechroot.d/PKGBUILD-libretools b/test/librechroot.d/PKGBUILD-libretools
new file mode 100644
index 0000000..dcc0f61
--- /dev/null
+++ b/test/librechroot.d/PKGBUILD-libretools
@@ -0,0 +1,20 @@
+pkgname='libretools-hello'
+pkgver=1.0
+license=('GPL')
+url='https://parabola.nu'
+
+pkgrel=1
+arch=(any)
+depends=(libretools)
+
+build() {
+ cd "$srcdir"
+ echo '#!/bin/sh' > hello.sh
+ echo 'echo Hello, world!' >> hello.sh
+ echo 'lsof' >> hello.sh
+}
+
+package() {
+ cd "$srcdir"
+ install -Dm755 hello.sh "$pkgdir"/usr/bin/libretools-hello
+}