summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--src/chroot-tools/makechrootpkg.sh.patch13
1 files changed, 7 insertions, 6 deletions
diff --git a/src/chroot-tools/makechrootpkg.sh.patch b/src/chroot-tools/makechrootpkg.sh.patch
index 817eaa5..8c42089 100644
--- a/src/chroot-tools/makechrootpkg.sh.patch
+++ b/src/chroot-tools/makechrootpkg.sh.patch
@@ -1,5 +1,5 @@
--- makechrootpkg.sh.in 2014-01-05 18:51:41.463720929 -0500
-+++ makechrootpkg.sh.ugly 2014-02-05 19:01:17.583560384 -0500
++++ makechrootpkg.sh.ugly 2014-02-05 19:59:10.991879605 -0500
@@ -12,6 +12,7 @@
shopt -s nullglob
@@ -227,11 +227,12 @@
ln -sft /srcdest /srcdest_host/*
ln -sft /startdir /startdir_host/*
-@@ -314,8 +369,25 @@
+@@ -314,8 +369,26 @@
cp /startdir_host/PKGBUILD* .
chown nobody PKGBUILD*
+ # Sync deps now, as networking may be disabled during _chrootbuild
++ cp /repo/repo.db /var/lib/pacman/sync/repo.db
+ sudo -u nobody makepkg "${makepkg_args[@]}" -eo
+}
+
@@ -253,7 +254,7 @@
echo "Can't write to PKGBUILD!"
exit 1
fi
-@@ -333,12 +405,24 @@
+@@ -333,12 +406,24 @@
exit 0
}
@@ -278,7 +279,7 @@
for l in "$copydir"/logdest/*; do
[[ $l == */logpipe.* ]] && continue
chown "$src_owner" "$l"
-@@ -352,6 +436,10 @@
+@@ -352,6 +437,10 @@
}
# }}}
@@ -289,7 +290,7 @@
umask 0022
load_vars /etc/makepkg.conf
-@@ -363,30 +451,45 @@
+@@ -363,30 +452,45 @@
[[ -d $SRCPKGDEST ]] || SRCPKGDEST=$PWD
[[ -d $LOGDEST ]] || LOGDEST=$PWD
@@ -341,7 +342,7 @@
if (( ret != 0 )); then
if $temp_chroot; then
-@@ -397,3 +500,4 @@
+@@ -397,3 +501,4 @@
else
true
fi