summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rwxr-xr-xlibrecommit18
-rwxr-xr-xlibremakepkg18
-rwxr-xr-xlibrerelease52
-rw-r--r--libretools.conf26
4 files changed, 87 insertions, 27 deletions
diff --git a/librecommit b/librecommit
index a1c1d01..f3ad816 100755
--- a/librecommit
+++ b/librecommit
@@ -1,4 +1,22 @@
#!/bin/bash
+# Copyright 2010 Nicolás Reynolds
+
+# ---------- GNU General Public License 3 ----------
+
+# This file is part of Parabola.
+
+# Parabola is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+
+# Parabola is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+
+# You should have received a copy of the GNU General Public License
+# along with Parabola. If not, see <http://www.gnu.org/licenses/>.
if [ ! -e PKGBUILD ]; then exit 1; fi
diff --git a/libremakepkg b/libremakepkg
index 9f02f84..cab6b9c 100755
--- a/libremakepkg
+++ b/libremakepkg
@@ -1,4 +1,22 @@
#!/bin/bash
+# Copyright 2010 Nicolás Reynolds
+
+# ---------- GNU General Public License 3 ----------
+
+# This file is part of Parabola.
+
+# Parabola is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+
+# Parabola is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+
+# You should have received a copy of the GNU General Public License
+# along with Parabola. If not, see <http://www.gnu.org/licenses/>.
if [ $UID -ne 0 ]; then
echo "This script must be run as root"
diff --git a/librerelease b/librerelease
index 8cfa877..c27c3a2 100755
--- a/librerelease
+++ b/librerelease
@@ -1,30 +1,28 @@
#!/bin/bash
-
# Librerelease
# Uploads packages into free/ repo
-# Config
-# SSH host, it's better if you have it configured on ~/.ssh/config
-# with ControlMaster auto (and a shell opened somewhere else)
-#
-# Example:
-# Host *
-# Protocol 2
-# ControlMaster auto
-# ControlPath /tmp/ssh-%r@%h:%p
-#
-# Host parabola
-# Port 22
-# HostName parabolagnulinux.org
-# User parabolavnx
-# IdentityFile ~/.ssh/id_rsa
-#
-# $ cd pkgbuild/dir
-# $ ssh parabola -fN
-# $ librerelease extra
-
-host=parabola
-dir=parabolagnulinux.org/repo/free
+# Copyright 2010 Nicolás Reynolds
+
+# ---------- GNU General Public License 3 ----------
+
+# This file is part of Parabola.
+
+# Parabola is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+
+# Parabola is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+
+# You should have received a copy of the GNU General Public License
+# along with Parabola. If not, see <http://www.gnu.org/licenses/>.
+
+source /etc/libretools.conf
+
batchfile=/tmp/librerelease_batchfile.$$
# End Config
@@ -63,16 +61,16 @@ for _arch in ${arch[@]}; do
pkgfile="$PKGDEST/$pkg-$pkgver-$pkgrel-$_arch$PKGEXT"
if [ -e "$pkgfile" ]; then
# This has to be moved to repo-maintainer
- ssh parabola mv $dir/$repo/os/$_arch/$pkg-*-*-$_arch$PKGEXT $dir/old/
+ ssh parabola mv ${PARABOLAHOST}/$repo/os/$_arch/$pkg-*-*-$_arch$PKGEXT ${LIBREDESTDIR}/old/
- to_sftp "put $pkgfile $dir/$repo/os/$_arch/"
+ to_sftp "put $pkgfile ${PARABOLAHOST}/$repo/os/$_arch/"
fi
done
done
makepkg --source
-to_sftp "put $SRCPKGDEST/$pkgname-$pkgver-$pkgrel$SRCEXT ${dir%free}/pkgbuilds/$repo"
+to_sftp "put $SRCPKGDEST/$pkgname-$pkgver-$pkgrel$SRCEXT ${LIBRESRCDIR}/$repo"
-sftp -b ${batchfile} $host
+sftp -b ${batchfile} ${PARABOLAHOST}
exit 0
diff --git a/libretools.conf b/libretools.conf
index 86a40e8..9fe2b4b 100644
--- a/libretools.conf
+++ b/libretools.conf
@@ -10,3 +10,29 @@ CHCOPY=copy
# Obtains CacheDir from pacman.conf
CACHEDIR=`grep "^CacheDir" /etc/pacman.conf | cut -d'=' -f2`
+# Parabola hostname (should be the same used on ssh_config
+PARABOLAHOST=parabola
+
+# Server destination of libre packages
+LIBREDESTDIR=parabolagnulinux.org/repo/free
+LIBRESRCDIR=parabolagnulinux.org/repo/pkgbuilds
+
+# Recommended SSH Config
+# SSH host, it's better if you have it configured on ~/.ssh/config
+# with ControlMaster auto (and a shell opened somewhere else)
+#
+# Example:
+# Host *
+# Protocol 2
+# ControlMaster auto
+# ControlPath /tmp/ssh-%r@%h:%p
+#
+# Host parabola
+# Port 22
+# HostName parabolagnulinux.org
+# User parabolavnx
+# IdentityFile ~/.ssh/id_rsa
+#
+# $ cd pkgbuild/dir
+# $ ssh parabola -fN
+# $ librerelease extra