summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rwxr-xr-xfullpkg26
1 files changed, 13 insertions, 13 deletions
diff --git a/fullpkg b/fullpkg
index 39d4fa9..21bef16 100755
--- a/fullpkg
+++ b/fullpkg
@@ -175,8 +175,8 @@ function find_deps {
echo "repo=$repo" > "${build_dir}/${pkgbase}/.INFO"
fi
-# Inform the current package
- msg2 "${pkgbase}-${fullver}"
+# Inform the current package plus a space for every level for indent
+ msg2 "%${level}s${pkgbase}-${fullver}"
## Check next levels
# Clean version checking
@@ -202,17 +202,17 @@ function find_deps {
# if search pkgname in repo doesn't work
# this should find pkgsplits
- elif _dir=($(find "$ABSROOT/${_repo}" -type f -name PKGBUILD -print0 2>/dev/null | \
- "xargs" -0 -e grep -HEw "pkgname=|pkgbase=|provides=" | grep -w "$_dep" 2>&1));
- then
- _dir=$(dirname $(echo $_dir | cut -d: -f1))
- plain "guess for $_dep -> $_dir"
- pushd $_dir > /dev/null
- $0 -c -d ${build_dir} -l ${next_level}
-# Circular deps must fail
- [ $? -eq 20 ] && return 20
- popd > /dev/null
- break 1 # found, go to next dep
+# elif _dir=($(find "$ABSROOT/${_repo}" -type f -name PKGBUILD -print0 2>/dev/null | \
+# "xargs" -0 -e grep -HEw "pkgname=|pkgbase=|provides=" | grep -w "$_dep" 2>&1));
+# then
+# _dir=$(dirname $(echo $_dir | cut -d: -f1))
+# plain "guess for $_dep -> $_dir"
+# pushd $_dir > /dev/null
+# $0 -c -d ${build_dir} -l ${next_level}
+## Circular deps must fail
+# [ $? -eq 20 ] && return 20
+# popd > /dev/null
+# break 1 # found, go to next dep
else
echo "dep_not_found:$_dep:$_repo" >> $build_dir/log