summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rwxr-xr-xfullpkg3
1 files changed, 2 insertions, 1 deletions
diff --git a/fullpkg b/fullpkg
index 213bf5e..14c4e9f 100755
--- a/fullpkg
+++ b/fullpkg
@@ -162,8 +162,9 @@ function find_deps {
# if search pkgname in repo doesn't work
# this should find pkgsplits
elif _dir=($(find "$ABSROOT/${_repo}" -type f -name PKGBUILD -print0 | \
- "xargs" -0 -e grep -HEw "pkgname|pkgbase|provides" | grep $_dep 2>&1));
+ "xargs" -0 -e grep -HEw "pkgname=|pkgbase=|provides=" | grep $_dep 2>&1));
then
+ plain "guess for $_dep -> $_dir"
pushd $(dirname $(echo $_dir | cut -d: -f1)) > /dev/null
$0 -c -d ${build_dir} -l ${next_level}
# Circular deps must fail