summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rwxr-xr-xlibrerepkg5
-rw-r--r--rePKGBUILD.proto28
2 files changed, 30 insertions, 3 deletions
diff --git a/librerepkg b/librerepkg
index ba8dea1..11962ff 100755
--- a/librerepkg
+++ b/librerepkg
@@ -52,9 +52,8 @@ stdnull "tempdir=$(mktemp -d /tmp/$(basename $PWD).XXXXX)"
msg "Repackaging: $pkgname $pkgver-$pkgrel ($(date -u))"
cp ./* ${tempdir}/
stdnull "pushd ${tempdir}"
-mv rePKGBUILD PKGBUILD
msg2 "Updating md5sums"
-makepkg -g >> PKGBUILD
+makepkg -gp rePKGBUILD >> PKGBUILD
msg "Repackaging using makepkg"
-makepkg -Lc
+makepkg -Lcp rePKGBULD
stdnull "popd ${tempdir}"
diff --git a/rePKGBUILD.proto b/rePKGBUILD.proto
new file mode 100644
index 0000000..17342ce
--- /dev/null
+++ b/rePKGBUILD.proto
@@ -0,0 +1,28 @@
+# This is an example rePKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Your Name <youremail@domain.com>
+source PKGBUILD
+unset build package md5sums source
+_repo=
+source=(PKGBUILD
+ http://mirrors.kernel.org/archlinux/${_repo}/os/$CARCH/$pkgname-$pkgver.tar.gz
+ # files for pkg modifications
+ )
+
+build() {
+ cd "${srcdir}/"
+ rm .{INSTALL,PKGINFO} $_pkgbase-$pkgver-$_pkgrel-$CARCH.pkg.tar.xz
+ # actions for package modifications
+ # be sure to remove source files
+}
+
+package() {
+ cd ${srcdir}
+ cp -a ./* ${pkgdir}
+}
+
+
+# vim:set ts=2 sw=2 et: \ No newline at end of file