summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rwxr-xr-xfullpkg13
1 files changed, 7 insertions, 6 deletions
diff --git a/fullpkg b/fullpkg
index cbf2e47..9dd2ad8 100755
--- a/fullpkg
+++ b/fullpkg
@@ -10,13 +10,13 @@ source /usr/bin/libremessages
# Avoid /libretools dir doesn't exist errors
if [ -z $XDG_CONFIG_HOME ]; then
error "There's no XDG_CONFIG_HOME var set"
- OFLINE=true
-elif [ -r $XDG_CONFIG_HOME/libretools/libretools.conf ]; then
+ exit 1
+fi
# set queue_file and ban_file
+[ -e $XDG_CONFIG_HOME/libretools/libretools.conf ] && \
source $XDG_CONFIG_HOME/libretools/libretools.conf
- queue_file=$XDG_CONFIG_HOME/libretools/queue
- ban_file=$XDG_CONFIG_HOME/libretools/ban
-fi
+queue_file=$XDG_CONFIG_HOME/libretools/queue
+ban_file=$XDG_CONFIG_HOME/libretools/ban
##### START FUNCTIONS #####
@@ -138,7 +138,7 @@ get_full_version() {
function cleanup {
# Do nothing OR
# Already cleaned
- [ "${do_cleanup}" = "n" || ! -d ${build_dir} ] && return 0
+ [[ "${do_cleanup}" = "n" || ! -d ${build_dir} ]] && return 0
# Only do cleanup on level 0
msg "Cleaning up..."
@@ -152,6 +152,7 @@ function find_deps {
source PKGBUILD
local repo=${repo:-$(guess_repo)}
local pkgbase=${pkgbase:-${pkgname[0]}}
+ local epoch=${epoch:-0}
local fullver=$(get_full_version ${epoch} ${pkgver} ${pkgrel})
# If package and correct ${fullver} is built exit