summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rwxr-xr-xlibrestage13
1 files changed, 6 insertions, 7 deletions
diff --git a/librestage b/librestage
index 2ac8adc..933a7e7 100755
--- a/librestage
+++ b/librestage
@@ -55,7 +55,7 @@ fi
}
# Source the needed files
-source PKGBUILD
+source ./PKGBUILD
source /etc/makepkg.conf
[[ -e ~/.makepkg.conf ]] && source ~/.makepkg.conf
@@ -70,20 +70,19 @@ for _arch in ${arch[@]}; do
pkgfile="$PKGDEST/$pkg-$pkgver-$pkgrel-$_arch$PKGEXT"
if [ -e "${pkgfile}" ]; then
-
+ echo found ${pkgfile}
for _repo in ${repos[@]}; do
cp "${pkgfile}" "${WORKDIR}/staging/${_repo}/" || {
echo "Can't put ${pkgfile} on [staging]"
exit 1
- }
-
+ } && {
+ echo "${pkg} staged on [${_repo}]"
+ }
done
fi
done
done
-echo "${pkgname[@]} staged on [${repos[@]}]"
-
-exit 0
+exit 0 \ No newline at end of file