summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rwxr-xr-xadd-mips64el6
-rwxr-xr-xfullpkg8
2 files changed, 12 insertions, 2 deletions
diff --git a/add-mips64el b/add-mips64el
new file mode 100755
index 0000000..e06d857
--- /dev/null
+++ b/add-mips64el
@@ -0,0 +1,6 @@
+#!/bin/bash
+# Change all arch array that aren't any or mips64el already
+
+find -name 'PKGBUILD' -exec sed -i "s/^\(arch=([^)anym]\+\))/\1 'mips64el')/" '{}' \;
+
+exit $?
diff --git a/fullpkg b/fullpkg
index 074662e..c723f8e 100755
--- a/fullpkg
+++ b/fullpkg
@@ -4,9 +4,13 @@
# * Detect circular builds
# * Detect pkgnames by provides, replaces, etc. instead of dir tree
+[[ ! -r PKGBUILD ]] && {
+ echo "This isn't a build directory"
+ exit 1
+}
-tmp_dir=$(mktemp -d)
-queue_file=$(mktemp)
+tmp_dir=$(mktemp -d /tmp/$(basename $PWD).XXXXXX)
+queue_file=$(mktemp /tmp/queue.XXXXXX)
[[ ! -w $queue_file ]] && exit 1
source /etc/makepkg.conf