summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rwxr-xr-xfullpkg4
-rwxr-xr-xlibremakepkg3
2 files changed, 3 insertions, 4 deletions
diff --git a/fullpkg b/fullpkg
index 427b606..794b191 100755
--- a/fullpkg
+++ b/fullpkg
@@ -86,7 +86,7 @@ quit() {
}
source PKGBUILD
-msg ":: Building ${pkgbase} ${pkgname[@]}"
+msg "Building ${pkgbase} ${pkgname[@]}"
trap "quit" SIGTERM SIGKILL
@@ -111,7 +111,7 @@ deps=$(echo "${depends[@]} ${makedepends[@]} ${pkgdeps[@]}" | \
sort -u)
msg "Checking dependencies"
-plain "$_deps"
+plain "${deps[@]}"
msg "Syncing database"
sudo pacman -Sy
diff --git a/libremakepkg b/libremakepkg
index 78ebefb..8cce89d 100755
--- a/libremakepkg
+++ b/libremakepkg
@@ -39,8 +39,7 @@ pkgbuild-check-nonfree ||{
CLEAN="-c"
msg "Updating the main chroot"
- mount -o bind ${CACHEDIR} ${CHROOTDIR}/${CHROOT}/var/cache/pacman/pkg || exit 1
- mkarchroot -u -- ${CHROOTDIR}/${CHROOT}
+ mkarchroot -c ${CACHEDIR} -u -- ${CHROOTDIR}/${CHROOT}
mount -o bind ${CACHEDIR} ${CHROOTDIR}/${CHCOPY}/var/cache/pacman/pkg || exit 1
}