summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rwxr-xr-xfullpkg8
1 files changed, 6 insertions, 2 deletions
diff --git a/fullpkg b/fullpkg
index b75bf32..434b793 100755
--- a/fullpkg
+++ b/fullpkg
@@ -4,9 +4,13 @@
# * Detect circular builds
# * Detect pkgnames by provides, replaces, etc. instead of dir tree
+[[ ! -r PKGBUILD ]] && {
+ echo "This isn't a build directory"
+ exit 1
+}
-tmp_dir=$(mktemp -d)
-queue_file=$(mktemp)
+tmp_dir=$(mktemp -d /tmp/$(basename $PWD).XXXXXX)
+queue_file=$(mktemp /tmp/queue.XXXXXX)
[[ ! -w $queue_file ]] && exit 1
source /etc/makepkg.conf