summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--src/chroot-tools/makechrootpkg.sh.patch26
1 files changed, 15 insertions, 11 deletions
diff --git a/src/chroot-tools/makechrootpkg.sh.patch b/src/chroot-tools/makechrootpkg.sh.patch
index 8c42089..540e6ba 100644
--- a/src/chroot-tools/makechrootpkg.sh.patch
+++ b/src/chroot-tools/makechrootpkg.sh.patch
@@ -1,5 +1,5 @@
--- makechrootpkg.sh.in 2014-01-05 18:51:41.463720929 -0500
-+++ makechrootpkg.sh.ugly 2014-02-05 19:59:10.991879605 -0500
++++ makechrootpkg.sh.ugly 2014-02-09 20:20:25.021630727 -0500
@@ -12,6 +12,7 @@
shopt -s nullglob
@@ -227,13 +227,19 @@
ln -sft /srcdest /srcdest_host/*
ln -sft /startdir /startdir_host/*
-@@ -314,8 +369,26 @@
- cp /startdir_host/PKGBUILD* .
- chown nobody PKGBUILD*
+@@ -316,11 +371,29 @@
+ # Safety check
+ if [[ ! -w PKGBUILD ]]; then
++ # XXX: internationalize this message
+ echo "Can't write to PKGBUILD!"
+ exit 1
+ fi
+
+- sudo -u nobody makepkg "${makepkg_args[@]}" || exit 1
+ # Sync deps now, as networking may be disabled during _chrootbuild
+ cp /repo/repo.db /var/lib/pacman/sync/repo.db
-+ sudo -u nobody makepkg "${makepkg_args[@]}" -eo
++ sudo -u nobody makepkg "${makepkg_args[@]}" -o
+}
+
+_chrootbuild() {
@@ -248,12 +254,10 @@
+
+ cd /startdir
+
- # Safety check
- if [[ ! -w PKGBUILD ]]; then
-+ # XXX: internationalize this message
- echo "Can't write to PKGBUILD!"
- exit 1
- fi
++ sudo -u nobody makepkg "${makepkg_args[@]}" -e || exit 1
+
+ if $run_namcap; then
+ pacman -S --needed --noconfirm namcap
@@ -333,12 +406,24 @@
exit 0
}