summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rwxr-xr-xsrc/chroot-tools/librechroot21
1 files changed, 15 insertions, 6 deletions
diff --git a/src/chroot-tools/librechroot b/src/chroot-tools/librechroot
index d5b677c..92bbb94 100755
--- a/src/chroot-tools/librechroot
+++ b/src/chroot-tools/librechroot
@@ -37,6 +37,11 @@ usage() {
echo "Usage: $cmd [OPTIONS] COMMAND [ARGS...]"
echo 'Interacts with an archroot (arch chroot).'
echo ''
+ echo 'This is configured with `chroot.conf`, either in'
+ echo '`/etc/libretools.d/`, or `$XDG_CONFIG_HOME/libretools/`.'
+ echo 'The variables you may set are $CHROOTDIR, $CHROOT, and'
+ echo '$CHROOTEXTRAPKG'.
+ echo ''
echo 'There may be multiple chroots; they are stored in $CHROOTDIR.'
echo ''
echo 'Each chroot is named; the default is configured with $CHROOT.'
@@ -57,13 +62,14 @@ usage() {
echo " copy path : $copydir"
echo ''
echo 'If the chroot, or copy does not exist, it will be created'
- echo 'automatically.'
+ echo 'automatically. A chroot by default contains the packages in the'
+ echo 'group "base-devel", and any packages named in $CHROOTEXTRAPKG.'
echo ''
echo 'This command will make the following configuration changes in'
echo 'the chroot:'
- echo " - overwrite \`/etc/libretools.d/chroot.conf'"
- echo " - overwrite \`/etc/pacman.d/mirrorlist'"
- echo " - set \`CacheDir' in \`/etc/pacman.conf'"
+ echo ' - overwrite `/etc/libretools.d/chroot.conf`'
+ echo ' - overwrite `/etc/pacman.d/mirrorlist`'
+ echo ' - set `CacheDir` in `/etc/pacman.conf`'
echo ''
echo 'Creating a copy, deleting a copy, or syncing a copy can be fairly'
echo 'slow; but are very fast if $CHROOTDIR is on a btrfs partition.'
@@ -85,12 +91,15 @@ usage() {
echo ' install-file FILES... Like `pacman -U FILES...`'
echo ' install-name NAMES... Like `pacman -S NAMES...`'
echo ' update Like `pacman -Syu`'
- echo ' clean-pkgs Remove all "exta" packages from the chroot copy'
+ echo ' clean-pkgs Remove all packages from the chroot copy that'
+ echo ' are not in base-devel, $CHROOTEXTRAPKG, or'
+ echo ' named as a dependency in the file'
+ echo ' `/build/PKGBUILD` in the chroot copy.'
echo ' Other:'
echo ' run CMD... Run CMD in the chroot copy'
echo ' enter Enter an interactive shell in the chroot copy'
echo ' clean-repo Clean /repo in the chroot copy'
- echo ' help Show this message' # usage
+ echo ' help Show this message'
}
# Globals: $CHROOTDIR, $CHROOT, $COPY, $rootdir and $copydir