summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rwxr-xr-xsrc/treepkg4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/treepkg b/src/treepkg
index 1453f41..519dee5 100755
--- a/src/treepkg
+++ b/src/treepkg
@@ -128,7 +128,7 @@ CLEANUP=${C:-true}
# Skip BUILDORDER creation and build anything on BUILDDIR
BUILDNOW=${N:-false}
-if [ ! -z "${1}" -a ${DEPTH} -eq 0 ]; then
+if [[ ! -z $1 ]] && [[ $DEPTH -eq 0 ]]; then
BUILDNOW=true
fi
@@ -171,7 +171,7 @@ if ! ${BUILDNOW}; then
# Ask toru where's a PKGBUILD
depdir="$(toru-where ${_dep})"
- if [ -z "${depdir}" -o ! -d "${depdir}" ]; then
+ if [[ -z ${depdir} ]] || [[ ! -d ${depdir} ]]; then
# We specify the pkgname because we can't source the dep PKGBUILD
# Normally 'any' packages are missing from our work ABS
add_order "missing" "${_dep}"