summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rwxr-xr-xsrc/aur3
-rwxr-xr-xsrc/chroot-tools/librechroot7
-rwxr-xr-xsrc/librerepkg4
-rwxr-xr-xsrc/toru/toru-path2
4 files changed, 13 insertions, 3 deletions
diff --git a/src/aur b/src/aur
index 24d4317..3d07cd8 100755
--- a/src/aur
+++ b/src/aur
@@ -26,6 +26,9 @@ function usage {
echo
echo "This script will download packages from aur to the current dir"
echo "and check their license for nonfree issues."
+ echo
+ echo "Note: it depends on abs to be updated."
+ echo "Install 'abs-libre' and run \`abs\` as root before working with $0"
}
while getopts 'h' arg; do
diff --git a/src/chroot-tools/librechroot b/src/chroot-tools/librechroot
index c8e02b0..158828b 100755
--- a/src/chroot-tools/librechroot
+++ b/src/chroot-tools/librechroot
@@ -46,7 +46,12 @@ function usage {
function clean_chroot { # Clean packages with pacman
cp -a "$(dirname $0)/chcleanup" "${CHROOTDIR}/${CHROOTNAME}/clean"
- mkarchroot -r "cd /build; /clean" "${CHROOTDIR}/${CHROOTNAME}"
+ libremessages="$(grep "libremessages" /etc/libretools.conf | cut -d" " -f2)"
+
+ cat /etc/libretools.conf ${libremessages} | sed "/libremessages/d" > "${CHROOTDIR}/${CHROOTNAME}/etc/libretools.conf"
+
+
+ mkarchroot -r "sh -c 'cd /build; /clean'" "${CHROOTDIR}/${CHROOTNAME}"
}
function clean_repo {
diff --git a/src/librerepkg b/src/librerepkg
index d506003..5cb0fa3 100755
--- a/src/librerepkg
+++ b/src/librerepkg
@@ -60,11 +60,11 @@ for _arch in ${arch[@]}; do
stdnull pushd ${tempdir}
+ echo "export CARCH=${_arch}" >> PKGBUILD
+
msg2 "Updating md5sums"
makepkg -gp rePKGBUILD >> rePKGBUILD
- echo "export CARCH=${_arch}" >> rePKGBUILD
-
msg "Repackaging using makepkg"
makepkg -Lcdp rePKGBUILD ${makepkgflags}
diff --git a/src/toru/toru-path b/src/toru/toru-path
index 957f49b..baeaeb5 100755
--- a/src/toru/toru-path
+++ b/src/toru/toru-path
@@ -22,6 +22,8 @@ fi
fullrepos=()
for (( i = ${#REPOS[@]}-1 ; i >= 0 ; i-- )); do
${VERBOSE} && msg "Processing [%s]" ${REPOS[$i]}
+
+ [ -d "${ABSROOT}${REPOS[$i]}" ] && \
fullrepos+=("${ABSROOT}${REPOS[$i]}")
done
pkgbuilds=($(get_pkgbuilds ${fullrepos[@]}))