summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--po/subdir.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/po/subdir.mk b/po/subdir.mk
index 3cddb5d..b9a2575 100644
--- a/po/subdir.mk
+++ b/po/subdir.mk
@@ -5,7 +5,8 @@ locale = $(notdir $(srcdir))
domains = $(patsubst %.po,%,$(filter %.po,$(files.src.src)))
$(outdir)/%.mo: $(srcdir)/%.po $(call at.path,$(srcdir)/../%.pot)
- msgfmt -o $@ $<
+ msgcmp --use-untranslated $< $(word 2,$^)
+ msgfmt -c -o $@ $<
$(DESTDIR)$(localedir)/$(locale)/LC_MESSAGES/%.mo: $(outdir)/%.mo
install -T -Dm644 '$<' '$@'