summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rwxr-xr-xlibrechroot21
-rwxr-xr-xlibrepatch65
-rw-r--r--libretools.conf3
3 files changed, 81 insertions, 8 deletions
diff --git a/librechroot b/librechroot
index e43a3ee..9532214 100755
--- a/librechroot
+++ b/librechroot
@@ -37,16 +37,21 @@ else
source /etc/libretools.conf
fi
-mount -t proc proc $CHROOTDIR/$root/proc/
-mount -t sysfs sys $CHROOTDIR/$root/sys/
-mount -o bind /dev $CHROOTDIR/$root/dev/
+[[ ! -d $CHROOTDIR/$1/ ]] && {
+ echo "There's no $CHROOTDIR/$1"
+ exit 3
+}
+
+mount -t proc proc $CHROOTDIR/$1/proc/
+mount -t sysfs sys $CHROOTDIR/$1/sys/
+mount -o bind /dev $CHROOTDIR/$1/dev/
-cp -L /etc/resolv.conf $CHROOTDIR/$root/etc/resolv.conf
+cp -L /etc/resolv.conf $CHROOTDIR/$1/etc/resolv.conf
-chroot $CHROOTDIR/$root /bin/bash
+chroot $CHROOTDIR/$1 /bin/bash
-umount $CHROOTDIR/$root/proc/
-umount $CHROOTDIR/$root/sys/
-umount $CHROOTDIR/$root/dev/
+umount $CHROOTDIR/$1/proc/
+umount $CHROOTDIR/$1/sys/
+umount $CHROOTDIR/$1/dev/
exit 0
diff --git a/librepatch b/librepatch
new file mode 100755
index 0000000..713c156
--- /dev/null
+++ b/librepatch
@@ -0,0 +1,65 @@
+#!/bin/bash
+# Generates a patch for a nonfree PKGBUILD
+#
+# Copyright 2010 Nicolás Reynolds
+
+# ---------- GNU General Public License 3 ----------
+
+# This file is part of Parabola.
+
+# Parabola is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+
+# Parabola is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+
+# You should have received a copy of the GNU General Public License
+# along with Parabola. If not, see <http://www.gnu.org/licenses/>.
+
+usage() {
+ echo "Usage: $0 <pkgname> [<pkgname2> ...]"
+ echo "Requirements:"
+ echo "* Have a <pkgname>/ directory with nonfree build scripts inside"
+ echo "* Have a <pkgname>-libre/ directory with libre build scripts inside"
+}
+
+# Load custom config or system-wide config
+custom_config=$XDG_CONFIG_HOME/libretools/libretools.conf
+if [ -e $custom_config ]; then
+ source $custom_config
+else
+ source /etc/libretools.conf
+fi
+
+# Print usage if no package has been given
+[[ -z "$@" ]] && {
+ usage
+ exit 1
+}
+
+
+for package in $@; do
+# Continue on errors
+ [[ ! -d ./${package} || ! -d ./${package}-libre ]] && {
+ echo "Error: no matching ${package} and ${package}-libre found"
+ continue
+ }
+
+ [[ ! -f ./${package}/PKGBUILD || ! -f ./${package}-libre/PKGBUILD ]] && {
+ echo "Error: no matching PKGBUILDs found for ${package}-libre"
+ continue
+ }
+
+ source ./${package}-libre/PKGBUILD
+ [[ -z ${pkgbase} ]] && pkgbase=${pkgname}
+
+# Generate a diff file, no -r since we don't want to patch src/ nor pkg/
+ diff -au ./${package} ./${package}-libre >> $PATCHDIR/${pkgbase}-${pkgver}-${pkgrel}.patch
+
+done
+
+exit 0
diff --git a/libretools.conf b/libretools.conf
index a83c8c4..05db5ce 100644
--- a/libretools.conf
+++ b/libretools.conf
@@ -10,6 +10,9 @@ CHCOPY=copy
# Obtains CacheDir from pacman.conf
CACHEDIR=`grep "^#\?CacheDir" /etc/pacman.conf | cut -d'=' -f2`
+# Directory where you store PKGBUILD patches
+PATCHDIR=
+
# Parabola hostname (should be the same used on ssh_config
PARABOLAHOST=parabola