summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD51
-rw-r--r--libretools.install33
2 files changed, 0 insertions, 84 deletions
diff --git a/PKGBUILD b/PKGBUILD
deleted file mode 100644
index ad92640..0000000
--- a/PKGBUILD
+++ /dev/null
@@ -1,51 +0,0 @@
-# Maintainer: Joshua Haase <hahj87@gmail.com
-# Contributor: fauno <fauno@kiwwwi.com.ar>
-
-pkgname=libretools
-pkgver=$(date +%Y%m%d)
-pkgrel=1
-pkgdesc="Scripts for easing Parabola's tasks"
-arch=('any')
-url="http://parabolagnulinux.org"
-license=('GPL3+')
-depends=(wget pacman devtools)
-makedepends=(git)
-backup=(etc/libretools.conf)
-install=libretools.install
-source=(libretools.install)
-md5sums=('07d2e7b0a1250d888fccc10969c7f436')
-
-_gitroot="http://projects.parabolagnulinux.org/libretools.git"
-_gitname="libretools"
-
-build() {
- cd "$srcdir"
- ## Git checkout
- if [ -d $srcdir/${_gitname} ] ; then
- msg "Git checkout: Updating existing tree"
- cd ${_gitname} && git pull origin
- msg "Git checkout: Tree has been updated"
- else
- msg "Git checkout: Retrieving sources"
- git clone ${_gitroot}
- fi
- msg "Checkout completed"
- ## Build
-}
-
-package() {
- install -d ${pkgdir}/usr/bin
- install -d ${pkgdir}/etc
-
- install -m644 ${_gitname}/libretools.conf ${pkgdir}/etc/
-
-
- install -m755 ${_gitname}/librechroot ${pkgdir}/usr/bin/
- install -m755 ${_gitname}/librecommit ${pkgdir}/usr/bin/
- install -m755 ${_gitname}/libremakepkg ${pkgdir}/usr/bin/
- install -m755 ${_gitname}/librediff ${pkgdir}/usr/bin/
- install -m755 ${_gitname}/librerelease ${pkgdir}/usr/bin/
- install -m755 ${_gitname}/pkgbuild-check-nonfree ${pkgdir}/usr/bin/
-
-}
-
diff --git a/libretools.install b/libretools.install
deleted file mode 100644
index d2876ff..0000000
--- a/libretools.install
+++ /dev/null
@@ -1,33 +0,0 @@
-
-# arg 1: the new package version
-post_install() {
- cat <<EOF
-
-For using libremakepkg /etc/libretools.conf to fit your needs.
-
-For the scripts that can be run as normal user you can make
-custom configuration by copying /etc/libretools.conf to
-\$XDG_CONFIG_HOME/libretools/libretools.conf
-
-You should add this to your ~/.ssh/config file:
-
-# Parabola Host
-Host parabola
- Port 22
- HostName repo.parabolagnulinux.org
- User parabolavnx
- IdentityFile ~/.ssh/id_rsa
-# End Parabola Host
-
-Edit IdentityFile as needed.
-
-EOF
-}
-
-## arg 1: the new package version
-## arg 2: the old package version
-post_upgrade() {
- post_install
-}
-
-# vim:set ts=2 sw=2 et: