summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile2
-rwxr-xr-xtest/testenv (renamed from test/runtests)2
2 files changed, 2 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 928878b..efea3d2 100644
--- a/Makefile
+++ b/Makefile
@@ -27,7 +27,7 @@ all: PHONY build
build: PHONY build-libretools build-doc
install: PHONY install-libretools install-doc
check:
- @cd test && ./runtests
+ @cd test && ./testenv roundup
%-doc: PHONY doc
$(MAKE) -C doc $*
diff --git a/test/runtests b/test/testenv
index 7410032..131eed2 100755
--- a/test/runtests
+++ b/test/testenv
@@ -15,7 +15,7 @@ export XDG_CACHE_HOME="$home/.cache"
export XDG_CONFIG_HOME="$home/.config"
# Run the tests
-roundup
+eval "$@"
ret=$?
# Clean up