summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--common.each.tail.mk8
-rw-r--r--common.once.head.mk4
2 files changed, 7 insertions, 5 deletions
diff --git a/common.each.tail.mk b/common.each.tail.mk
index 58dfa8e..ffc4f47 100644
--- a/common.each.tail.mk
+++ b/common.each.tail.mk
@@ -1,4 +1,4 @@
-# Copyright (C) 2015 Luke Shumaker
+# Copyright (C) 2015, 2016 Luke Shumaker
#
# This program is free software: you can redistribute it and/or modify
# it under the terms of the GNU Affero General Public License as published by
@@ -13,6 +13,12 @@
# You should have received a copy of the GNU Affero General Public License
# along with this program. If not, see <http://www.gnu.org/licenses/>.
+ifneq ($(sort $(wildcard $(addprefix $(srcdir)/,$(devtools-files)))),$(sort $(addprefix $(srcdir)/,$(devtools-files))))
+ifeq ($(wildcard $(devtoolsdir)/),)
+$(error config.mk:devtoolsdir points to a non-existant directory: $(devtoolsdir))
+endif
+endif
+
am_src_files += $(libretools-srcs)
am_gen_files += .srcfiles.mk $(devtools-files)
am_out_files += $(filter-out $(am_src_files) $(am_gen_files),$(libretools-files)) \
diff --git a/common.once.head.mk b/common.once.head.mk
index 45d51b4..d7faab8 100644
--- a/common.once.head.mk
+++ b/common.once.head.mk
@@ -20,10 +20,6 @@ MAKEFLAGS += --no-builtin-rules --no-builtin-variables
.PHONY: FORCE
-ifeq ($(wildcard $(devtoolsdir)/),)
-$(error config.mk:devtoolsdir points to a non-existant directory: $(devtoolsdir))
-endif
-
write-ifchanged = $(topsrcdir)/write-ifchanged
# Magic for tracking variables that affect files. If a file changes