summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--src/devtools/.gitignore2
-rw-r--r--src/devtools/Makefile9
-rw-r--r--src/devtools/lib/.gitignore2
-rw-r--r--src/devtools/lib/common.sh.top13
4 files changed, 20 insertions, 6 deletions
diff --git a/src/devtools/.gitignore b/src/devtools/.gitignore
index 06a1942..cce9a4c 100644
--- a/src/devtools/.gitignore
+++ b/src/devtools/.gitignore
@@ -1,4 +1,4 @@
*
!*/
!Makefile
-!*.patch
+!.gitignore
diff --git a/src/devtools/Makefile b/src/devtools/Makefile
index 18f1518..e0a7386 100644
--- a/src/devtools/Makefile
+++ b/src/devtools/Makefile
@@ -16,7 +16,7 @@ sysconfdir=/etc
docdir=$(datarootdir)/doc
-################################################################################
+######################################################################
pkglibexecdir=$(libexecdir)/libretools
@@ -67,14 +67,13 @@ indent = emacs --batch $1 \
@$(edit) <"$<" >"$@"
@chmod 755 "$@"
-lib/common.sh: %: %.in Makefile
+lib/common.sh: %: %.in %.top Makefile
@echo "GEN $@"
@{ \
- echo '#!/bin/bash -euE' && \
- echo '#!/bin/bash' && \
+ cat "$*.top" && \
echo 'if [[ -z $${_INCLUDE_COMMON_SH:-} ]]; then' && \
echo '_INCLUDE_COMMON_SH=true' && \
- cat "$<" && \
+ cat "$*.in" && \
echo 'fi'; } > "$@"
lib/makechrootpkg.sh.ugly: %.ugly: %.in %.patch Makefile
diff --git a/src/devtools/lib/.gitignore b/src/devtools/lib/.gitignore
new file mode 100644
index 0000000..9e428f9
--- /dev/null
+++ b/src/devtools/lib/.gitignore
@@ -0,0 +1,2 @@
+!*.patch
+!*.top
diff --git a/src/devtools/lib/common.sh.top b/src/devtools/lib/common.sh.top
new file mode 100644
index 0000000..d59268d
--- /dev/null
+++ b/src/devtools/lib/common.sh.top
@@ -0,0 +1,13 @@
+#!/bin/bash -euE
+#!/bin/bash
+# This file is included by libremessages.
+# You should probably use libremessages instead of this.
+
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; version 2 of the License.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.